Anyone running OS 4.0 on 3Gs having WiFi issues?

Discussion in 'iPhone' started by Gromet, Apr 8, 2010.

  1. Gromet macrumors regular

    Gromet

    Joined:
    Jul 27, 2007
    #1
    Hey there all, I installed os 4.0 on my 3GS and everything seems to be working fine except my WiFi. It askes for my password, I enter it and it says "Unable to join"?>????

    2 Laptops, 2 iPads and my wife's iPhone are all on the wireless? I know the password is correct....

    WTF????

    ..Gromet
     
  2. JosephBergdoll macrumors 6502

    Joined:
    May 7, 2009
    Location:
    NYC
  3. Schtumple macrumors 601

    Schtumple

    Joined:
    Jun 13, 2007
    Location:
    benkadams.com
    #3
    It's almost as if it's a dev preview that's going to be prone to bugs and not a final golden master copy.

    Strange that.

    Try re-installing. Might help, if not, it's an early build, it's to be expected that it's not going to be 100% there otherwise we'd all have a lovely update waiting for us the next time we plugged our iPhones into iTunes.
     
  4. bitslap47 macrumors 6502a

    bitslap47

    Joined:
    Jul 9, 2007
    #4
    Yes. WiFi is broken for me. 3GS, Linksys dual band router running dd-wrt. Fine with everything else including iPad. Was fine prior to 4.0. even with Setup as new phone and no restore.
     
  5. javaGuru macrumors 6502a

    javaGuru

    Joined:
    Jul 15, 2007
    #5
    I'm having the same problem. I can't login into my wifi network at all. But, it connects the the wifi network at my Mom's house without any problems.
     
  6. ralfyx macrumors newbie

    Joined:
    Jan 13, 2007
    #6
    Same problem here too, cannot connect to any network.
     
  7. bornonjuly4 macrumors newbie

    Joined:
    Apr 8, 2010
    #7
    Same issue here

    I have a Linksys Plain vanilla Firmware WRT110 router setup with WPA2. Keep getting message "Unable to Join <SSID>"
     
  8. RichL macrumors 6502

    Joined:
    Jun 15, 2007
    Location:
    Chicago
  9. MisterWoofWoof macrumors newbie

    MisterWoofWoof

    Joined:
    Jul 14, 2009
    #9
    Same with me. I can't connect to my netgear or verizon router.
     
  10. Carlson-online macrumors member

    Joined:
    May 27, 2004
    #10
    Can't connect to my home network (Wireless N - DLink DIR655)
    Can connect at work to our Cisco Wireless G Network.
    Can't connect at work to out DLink Wireless N Network.

    So maybe the problem as something to do with Wireless N (or DLink stuff ? ).


    Both N networks have a b/g fallback
     
  11. bornonjuly4 macrumors newbie

    Joined:
    Apr 8, 2010
    #11
    Found A solution to wifi issues.

    Looks like the OS 4.0 has IPV6 set to automatic. Disabled this settting and changed the home wireless network from Mixed Mode to Wireless G only. Now the wifi seems to connect fine.

    I didn't test this with Wireless N only as my router (Cisco WRT110) always seems to have problems in this mode.

    :)
     
  12. mservidio macrumors newbie

    Joined:
    Jul 22, 2009
    #12
    I was having this same issues, and this has resolved some of the Wifi issues instantly.
     
  13. andybno1 macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #13
    I'm on a 3G phone and had wifi issues, I restored and then restored from backup and when I ran echofon and facebook even though I had a wifi signal full bars it kept saying my wifi had gone offline (which I knew it hadn't) but after a few tries I think it's working properly now
     
  14. hoits2000 macrumors member

    hoits2000

    Joined:
    May 21, 2008
    Location:
    NW Indiana
    #14
    Thanks guys!! This fixed it for me. Even with beta 2 problem still is there, bypassed it with this fix. Same router Cisco 110.
     
  15. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #15
    Where is this setting to change IPV6 to auto in the iPhone? Are you talking about the router?
     
  16. rsmith652 macrumors member

    Joined:
    Nov 13, 2007
  17. andybno1 macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #17
    try resetting network settings, I had wifi issues with beta 2 initially but after a reset oif network settings all seems ok
     
  18. mbonfig macrumors newbie

    Joined:
    Aug 10, 2010
    #18
    Same Issue

    Exact same thing happened to me after i upgraded my 3G to 4.0. At week or so later i upgraded to 4.0.1 thinking it might resolve the issue and at that point it got worse as it no longer even sees my wifi (or any wifi) SSID. I've searched on the web and seeing MANY other reports of this issue along with other problems. The only response that I have seen is that "Apple is investigating..." ... I really don't think that Apple is taking this seriously (or perhaps it part of a bigger plan???). I'll live this the problem until my cellular contract is up for renewal (~2 months). If it isn't resolved at that point my plan to move to another product ...
     
  19. Megalobyte macrumors 6502a

    Joined:
    Dec 30, 2007
    Location:
    Florida
    #19
    My ip4 has same issue on 4.0, it comes and goes. Sometimes it'll keep asking for my password, I enter it (correctly) still says it's wrong, or unable to join. Never had this on my 3GS pre 4.0. Must be a 4.0 thing.
     

Share This Page