Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Aftermath747

macrumors 6502
Original poster
Sep 16, 2015
264
211
Ever since installing iPadOS 16 on my iPad Pro 11”, I’ve experienced frequent drops in connection that I never had in 15.7.1. I installed 16.2 last night hoping those had finally been fixed. Much to my dismay, they’ve continued. Am I the only one?
 

SebCohen

macrumors regular
Feb 9, 2022
154
149
Mine seems to be fixed. It’s “snappier” and I don’t get those rondo Max Headroom hangs/pauses when loading. Or those times when Safari seems stuck on a webpage and you can’t go to another site where it doesn’t even seem to be loading. I always thought this was Private Relay issues, not wifi specific thought.

Actually my whole iPad (12.9/M1/512) seems smoother and faster to be honest.
 
  • Like
Reactions: Isamilis

RaceTripper

macrumors 68030
May 29, 2007
2,867
178
I just found this in a search, because I am getting contant WiFi dropouts on my 2021 M1 iPad pro 12.9. This only started after I upgraded to 16.2. IPadOS 16.1.x was fine. It’s really pretty bad too. Sometimes I have to reboot the iPad to get it working again, and sometimes it drops outs again within minutes.

I am not having these issues with iOS 16.2, just iPadOS 16.2, but the latter is a real FU mess and not very useable lately.
 
Last edited:
  • Like
Reactions: Saludos

Aftermath747

macrumors 6502
Original poster
Sep 16, 2015
264
211
The issue persists in iPadOS 16.3. :( I’m beginning to think it’s permanently broken in iPadOS 16 for me.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.