Anyone successfully made a USB installer for new 13" rMBP?

Discussion in 'MacBook Pro' started by bcaslis, Apr 22, 2013.

  1. bcaslis macrumors 68020

    Joined:
    Mar 11, 2008
    #1
    I'm trying to make a USB boot disk for a new 13" Retina MacBook Pro. I've booted using the recovery disk and told it to install on a 32GB USB stick. It downloads and then I reboot onto the SSD. I can copy the InstallESD.dmg successfully.

    I've then made an 8GB USB stick using the dmg image. I've tried both using Disk Utility and the Lion Diskmaker app. Both successfully make the USB stick but if I reboot onto this stick to test it, it starts the installer then get an error and quits. I've successfully down with other machines with both Lion and Mountain Lion. But it seems like the image downloaded from recovery wants to start an immediate install on the boot disk. If I boot from the 32GB stick it doesn't fail but start to immediately try to install on that drive.

    Anyone gotten this to work? I know that the normal Mountain Lion image can't be used because this machine needs 10.8.2 at least.
     
  2. jafingi macrumors 65816

    jafingi

    Joined:
    Apr 3, 2009
    Location:
    Denmark
    #2
    I think it will be easier to use CCC to make a bootable clone of your installed OSX.
     
  3. Brian Y macrumors 68040

    Joined:
    Oct 21, 2012
    #3
    Just make a regular 10.8 USB stick, and install the 10.8.3 combo update onto it (when running the combo update, select the USB drive as the target).

    This will update the installer to 10.8.3 which is fine for your computer.
     
  4. vbman213 macrumors 6502

    Joined:
    Apr 13, 2010
    #4
    Can you not just download a copy from the App store? This will contain 10.8.3. Then use the disk maker.
     
  5. Mr MM macrumors 65816

    Mr MM

    Joined:
    Jun 29, 2011
    #5
    I use this little tool

    http://blog.gete.net/lion-diskmaker-us/

    no need to mount or dismount and fail

    aside that you can actually see if your usb stick is actually working inside OSX, or at boot
     
  6. jNSK macrumors newbie

    Joined:
    Apr 9, 2013
    #6
    The version from the App Store is 10.8.3. Go to Purchases and option-click next to ML to download it.
     
  7. bcaslis thread starter macrumors 68020

    Joined:
    Mar 11, 2008
    #7
    Good suggestion and I tried but the same result. It seems after booting instead of going to the window which lets you select what to do (install, disk utility, etc...) it always boots right into the installer and tries to start instead on the boot disk (the 8GB USB stick). Very strange.
     
  8. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #8
    Use the program Mr MM linked to above. Download the Mountain Lion installer from the App Store, point Lion DiskMaker to it, and let it do its thing. It will take a while, but when finished, you should have a fully functional 10.8.3 bootable USB flash drive.
     
  9. bcaslis thread starter macrumors 68020

    Joined:
    Mar 11, 2008
    #9
    No, as I said in my first post I did that. It does the same thing as making the image using Disk Utility. It just boots directly into the installer which tries to install on the USB stick and fails.
     
  10. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #10
    Have you tried a different flash drive?

    It looks like you've already used two, but there might be some conflict between the drives and USB 3.0. Do you have a USB 3.0 drive you can test, as I know it can be really picky when it comes to peripherals.
     
  11. Mr MM macrumors 65816

    Mr MM

    Joined:
    Jun 29, 2011
    #11
    USB3 is a pos when it comes to installing OSes, I would go for a 8gb USB2 thumb drive, I have one for that purpose only

    actually one other thing, are you using filevault2?

    if you are after you unlock the drive it still doesnt allow you to install on the main drive, so you have to quit and run diskutility, wipe the main drive and proceed to install
     

Share This Page