Anyone Tried Spotlight Server with Snow Leopard Server Yet?

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Velin, Aug 28, 2009.

  1. Velin macrumors 65816

    Velin

    Joined:
    Jul 23, 2008
    Location:
    Hearst Castle
    #1
    We run OSX Server, but had problems with Leopard Spotlight. Especially when moving large amounts of data around (150+ gig), Leopard Spotlight seemed to either barf on, or destroy, the indexes when data was moved. Worse, Leopard Server either didn't create a new index when the move was complete, or people couldn't access them from their desktops. (We tried everything, including every UNIX/terminal command we could think of to rebuild the indexes.)

    So, anyone tried out Spotlight Server for Snow Leopard yet? Curious to see if it's more responsive. And definitely curious if you've moved some files around and did some Spotlight tests to see if Snow Leopard spit back correct results.
     
  2. Don.Key macrumors regular

    Joined:
    Jan 11, 2005
    #2
    Bump!

    I wonder the same!

    The Spotlight server would be a killer feature, if it worked.....
    It is treated by Apple as the red headed stepchild. Grrrr
     
  3. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #3
    I'm still kind of new to the server software; how would I turn it on? Does it index networked computers or just the server?
     
  4. Don.Key macrumors regular

    Joined:
    Jan 11, 2005
    #4
    Hi,

    You enable it on network sharepoints within server admin.

    If firsts indexes the share, then, in theory, all users which mount this sharepoint from the net can use their spotlight search field to search this share as well.

    It is a kick ass thing, when it works. Problem is that it never did cleanly for us, we search just one share with about 100 gig of documents and images, nothing really big or what our HW could not handle (Octo core 3ghz xserve, 8gb ram, fibre array).

    What happens is that once index is wiped and rebuild, it works, but after short while it will stop finding newly added or altered files on this share and after some time it might stop working entirely or show just some hits while there are clearly more then that.

    I am a professional UNIX system engineer which loves shell :D I know concept of permissions and co very well and I tried every thinkable thing located on the net to fix this but I gave up, it just does not work!

    I will get SL Server soon and install it on our test machine for a while to see how it runs, but sincerely I do not hold my breath...

    Regards
     
  5. Don.Key macrumors regular

    Joined:
    Jan 11, 2005
    #5
    Ok..

    I have SL server in use for some time now, in a nutshell Spotlight still screwed and broken.

    BUT here is the way which works in our case...

    (This basically assumes that you already have shared volumes which have search screwed up, if not - go to step 6, this is enough...)

    1) Remove all shares from Volume you want to index.
    2) Drop your entire Volume into Privacy list of Spotlight (In Preferences)
    3) Delete .Spotlight-V100 from the mount point / root of the Volume
    4) Remove Volume out of Spotlight Privacy list
    5) In shell, as root do: 'mdutil -Ea' (Attention, this will also rebuild all other indexes, if you want to rebuild only this volume: 'man mdutil'). Note: Re-Index will start within 30 minutes, I do not know why but that's the way it is, have patience for it to start!
    6) Re-create shares on the Volume, DO NOT enable spotlight searching on shares! It will still work!

    Once re-index is done, which might take many, many hours, your spotlight search will reliably work on shared volumes, also from network. We had it running like this for over a month now, while changing, adding and removing files, it always kept database up-to-date.

    One thing which 100% breaks spotlight is enabling search via shares....
     
  6. Serif macrumors regular

    Joined:
    Jul 10, 2008
    Location:
    UK
    #6
    Thanks very much for the report and workaround. Much appreciated. :)
     
  7. gheidkamp macrumors newbie

    Joined:
    Jul 17, 2010
    Location:
    Rethen, Lower Saxony, Germany
    #7
    Is it essential to remove and re-create the shares?

    Thanks for the valuable hint:

    I have been working for quite some time on a similar problem with 10.6.4 server. I have tried the suggested procedure, but yet avoided removing and re-creating the shares on my server volume. Currently spotlight searching works for about 30 minutes after index rebuild. And moving files around on the server seems to immediately break the index. Do you think, removing and re-creating the shares is essential ? And could avoiding it explain the stickiness of the problem?

    Thanks for your opinion!
     
  8. BornAgainMac macrumors 603

    BornAgainMac

    Joined:
    Feb 4, 2004
    Location:
    Florida Resident
    #8
    I do not have any shares on my server and spotlight breaks. There has to be something else that is causing Spotlight on the server to break so easily.
     

Share This Page