Anyone using Flip Video and iMovie 09? I need help!

Discussion in 'Mac Apps and Mac App Store' started by hellodon, Mar 4, 2009.

  1. hellodon macrumors 6502

    Joined:
    Jan 19, 2006
    #1
    When I first got my Flip Video I had iMovie 08....which I wasnt too fond of the features but it did enough to get by. I used it to edit a couple Flip video movies with absolutely no problem. It read the avi files fine and worked with them which was great!

    I installed iLife 09, and just recently tried iMovie 09 for the first time. Pulled some videos off of my Flip and dragged them into iMovie as I did with the Flip videos and iMovie 08. It looks like it imports them fine, but then in the preview panel it says "No Matching Video, choose a different option from the Show pop-up menu at the lower left corner". So i made sure that THAT menu says "All Clips" but still nothing is showing up.

    I tried using quicktime pro to convert the avi files to mov files and still nothing is showing up. I dont know what I could be doing wrong but this is awful! I was so excited to have the new BETTER iMovie and I can't even use it for the only thing I want to use it for. Anyone run into this or have a solution?

    Thanks in advance!
     
  2. superhonky macrumors newbie

    Joined:
    Feb 2, 2009
    #2
    Same issue here..........

    For the record, I am having the same problem. According to the
    iMovie docs...anything that Quicktime can play should be compat with
    iMovie...but that doesn't seem to be the case.

    Pls update this thread if you figure it out!
     
  3. superhonky macrumors newbie

    Joined:
    Feb 2, 2009
    #3
    I updated to the latest version of Perian..not sure if that is related...but telling you anyway.

    If you install the latest version of Flip Share
    http://www.theflip.com/app/fvsw/406/update/index.aspx

    Then import from the Flip...then export from the Flip Share program
    to a folder on your mac....then import into iMovie 09 the movies from the
    FLip movies are recognized.

    A PITA...but it works.

    Other related notes:
    http://support.apple.com/kb/HT1989

    http://support.apple.com/kb/HT3290
    which says the FLip is supported...so I think wemust be missing
    something obvious. Perian installs the 3ivx MPEG-4 codec (or it
    gets installed as part of the FlipShare install).


    --Note
    This also works after installing the codec:Go to http://www.theflip.com/support_home.shtml
    and put in imovie.
     
  4. hellodon thread starter macrumors 6502

    Joined:
    Jan 19, 2006
    #4
    Thanks a ton!

    I reinstalled the Flip software (if I remember correctly I may have just DRAGGED the application over from back up when my hard drive crashed and I got a new one so necessary components may have never been installed properly)

    And I installed Perian

    Did the export thing from my Flip software (which was pretty quick, thankfully) then imported into iMovie and it appears that I'm all set!

    Very thankful. I did a lot of searching on this issue and I couldnt find ANYTHING. I think we're seriously the only ones talking about it...so hopefully this post helps others.
     
  5. RemarkabLee macrumors 6502a

    Joined:
    Nov 14, 2007
    #5
    I have a Mino HD and it works find with iMovie '09 out the box, as Apple intended.
     
  6. sashok macrumors newbie

    Joined:
    Sep 17, 2007
    #6
    Clarified: the problem that I am running into is NOT using a Mino HD, but using a regular Mino. The same goes for the above posters.

    If not using the Flip software and importing directly into iMovie, the video file does not appear at all in the iMovie media browser, although it gets copied to the folder ~/Movies/iMove Events/iMovie project name here

    I can confirm that this is indeed a problem with iMovie 09: it doesn't recognize the AVI format created by the camera. To clarify, iMovie 09 is able to import other AVI files just fine, but not the ones created by the Flip camera.

    The Flip HD records in a different format than the regular Flip:
    The HD uses H.264 video compression, AAC audio compression, MP4 file format
    The Mino (regular) uses: Advanced Profile MPEG-4 AVI
    That's directly from the Flip specifications site

    I recommend we post to Apple's support board about this issue, since this is very annoying and the two companies should find a fix for this issue. The board appears to be "dead" at the current time.
     
  7. The Wedge macrumors regular

    Joined:
    Dec 31, 2009
    #7
    I'm having the same exact problem. Flip Mino (not HD) and brand new Mac with iMovie 09. The files simply do not work with this software, although I have Perian installed and I am able to view the files with quicktime.
     
  8. sharkync macrumors regular

    Joined:
    Aug 8, 2009
    Location:
    Raleigh
    #8
    For what it's worth - iMovie 09 works perfectly with the Kodak Zi8.
     
  9. bluewrx04 macrumors newbie

    Joined:
    Dec 25, 2010
    #9
    I just got the flip video today for xmas. I updated the software, and if you click on a video you upload by right clicking (dbltap two fingers) click export and export it to desktop, then (if you have the old imovie) drag it to imovie. (i just got done downloading the older imovie after looking for it online for 3 months. Newer version sucks butt and dumbed it down for grandma).
     

Share This Page