Anyone Using VirtualBox ?

Discussion in 'Windows, Linux & Others on the Mac' started by Cypress, Apr 2, 2008.

  1. Cypress macrumors newbie

    Joined:
    Jan 18, 2007
    #1
    Hi,

    Has anyone tried virtualbox on OS X, it is an open source virtualisation product that is available from Sun http://www.sun.com/download/index.jsp.
    Look under operating systems>virtualisation.

    I haven't tried it yet, just wondering what if anyone had any feedback.

    Regards

    Paul;
     
  2. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #2
    I like it, I used virtualbox on my Compaq previously, didn't realize it was bought by SUN.

    Its a great product, now i need to figure out if I can get hardware 3D..
     

    Attached Files:

  3. flopticalcube macrumors G4

    flopticalcube

    Joined:
    Sep 7, 2006
    Location:
    In the velcro closure of America's Hat
    #3
    I tried it a while back and its nice. It needs a coherence/unity mode and bootcamp compatibility to make me switch from VMware. If you don't want to pay, its not a bad option.
     
  4. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #4
    Hmmm...although I've got VMWare on my iMac this would do me quite well on the MBP for those few times I need it. Ta :)
     
  5. cr2sh macrumors 68030

    cr2sh

    Joined:
    May 28, 2002
    Location:
    downtown
    #5
    It amazes me that VirtualBox isn't hotter. No one ever talks about it and it's a FREE alternative to the $70 vmware fusion.

    I have it installed on my macbook and it's great, there are limitations.. but none that are annoying enough to justify the price tag of the other options.

    http://www.virtualbox.org/wiki/VirtualBox
     
  6. Ilomoga macrumors member

    Joined:
    Oct 29, 2007
    #6
    Before I got my MacBook I was using Linux as my productive system and for using Windows on it I used VirtualBox 1.5.x. There were two simple reasons for that: The first one was of course that it's free and offers you most features you need. The second one was that Windows in a virtual machine seemed to be faster on my PC with 512MB under Linux than with VMware (trial).

    I'm happy to see that now VirtualBox is also available for MacOSX in a Final version because I think it's a really good virtualization software.

    There's just one thing I wonder: I installed the 1.6 version on my MacBook and in the network configuration I can only choose NAT and Not Connected. Somebody knows why? In the 1.5.x version on Windows I could also choose host-only and bridged (like in VMware)
     
  7. MacUser2525 macrumors 68000

    MacUser2525

    Joined:
    Mar 17, 2007
    Location:
    Canada
    #7
    You missed the documented limitations of the OSX version that clearly states these are not functioning and will be addressed in a future version. Also if you are looking to get any information in/out of the virtual machine without jumping through hoops to do it then you will disappointed to find out as I was that the Guest Additions are not available for it as well meaning no shared folders for easy access to the host OS filesystem for transfers among other nice to have features.
     
  8. techmonkey macrumors 6502a

    Joined:
    Jun 8, 2007
    #8
    I am thinking about using VirtualBox, but are you saying its not possible to see shared folders from other systems on the network?
     
  9. MacUser2525 macrumors 68000

    MacUser2525

    Joined:
    Mar 17, 2007
    Location:
    Canada
    #9
    They did not show up in the Networking of the guest system the same as there was no virtual shared folder to access on the host system so no not that I could see, never tried an IP in a browser though so you may be able to get to them that way.
     
  10. Ilomoga macrumors member

    Joined:
    Oct 29, 2007
    #10
    Shared folders work - I could access them with \\vboxsvr\sharedfolder or something like that.

    I used it some time now and it's working very well - the only and VERY annoying thing is that it captures the whole keybord except the release key. I didn't think about that earlier but in VMware it worked perfect - With Apple+Tab I switched between Mac apps and with Alt+Arrow Keys I switched between Spaces - it didn't matter if I was in the VM or not. In VirtualBox these things don't work - as long as VirtualBox is the active application (or at least the VM) - which is very annoying ....

    EDIT: Found something out (didn't think of that because I didn't use it that way): Accessing the shared folders with \\vboxsvr\<name> in the address bar will NOT work (at least not with my machine), if i mount them in the command line with "net use X: \\vboxsvr\<name>" it works.
     

Share This Page