Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Ethosik

Contributor
Original poster
Oct 21, 2009
7,824
6,727
Ever since the iOS 16 release and possibly a firmware update?? I need to restart my AirPods Max daily now before it can connect. Holding both buttons until it flashes amber. I also tried a full reset and it didn’t help.

Daily when I put the headphones on it just does nothing. It has noise cancellation off, buttons don’t respond, iPhone/iPad/Mac state the device connected but it doesn’t.

Is this happening to anyone else? Got any other suggestions? Sometimes I need to restart twice in a day too.
 
  • Like
Reactions: jeffirl

jon3543

macrumors 6502a
Sep 13, 2010
609
266
No APM problems here, but I use it wireless with my PC. All my problems are with the AirPods Pro 2, which is garbage so far in terms of connection problems.
 

patrickplaggenborg

macrumors newbie
Aug 20, 2015
28
13
Amsterdam, The Netherlands
Hmmm I've started to have the exact same issue.

Every time the AirPods Max are not used for some time they won't connect anymore. Need to reset them (not factory reset) and everything works fine.

Tried factory reset as well. Didn't fix the problem.

First I thought it was a battery issue. I have them when they first came out, Januari 2021, and use them a lot. But battery seems still pretty solid.

Also thought it was a head detection problem. But after the reset the head detection works perfectly. On, off, on, off. Perfectly recognized.

Closest I've come to fixing it is not putting the headphones in the carrying case with the magnets that trigger the AirPods Max to go into sleep mode. Not sure how it drains the battery faster though.
 

MRrainer

macrumors 68000
Aug 8, 2008
1,528
1,107
Zurich, Switzerland
This looks like that with some units, there might be something "not quite right" with the hardware and the software doesn't know how to handle it.

As there's likely no easy way to diagnose that for Apple-staff, they just replace those devices (and probably make a claim towards the manufacturer....).
 

bbednarz

macrumors 65816
Nov 16, 2017
1,409
3,740
Chicago
I have this issue from time to time. at first it was happening kind of often, but lately it's been better and restarting them always fixes it. annoying for the price, but oh well.
 

MRrainer

macrumors 68000
Aug 8, 2008
1,528
1,107
Zurich, Switzerland
I really do want to buy them. But I also want to use them very much longer than two years. Recently, sales of used APMs have picked up quite a bit around here. Hopefully, they fix all this in the next version (while not introducing different bugs).
 

BChertoff

macrumors newbie
Sep 21, 2023
1
0
I updated to iOS 17 and out of nowhere I'm having this problem now every day. Hoping it's something that will be resolved in a forthcoming update. It's got to be iOS. Odd, however, that the problem manifests on my laptop as well. If anyone has any tips or solutions, I'd be very eager to hear!
 

malreynolds

macrumors member
Jun 22, 2007
86
4
I have two pairs of AirPod Max with the exact same problem, and it happened recently. I have to restart every day for both pairs. This makes me think it's either a firmware issue or like some kind of iCloud identification issue? Since it happened to both my pairs at the same time.
 

josevazrodrigues

macrumors newbie
Sep 25, 2023
4
1
It happened to me as well. My APM were perfectly fine since day one, and out of nowhere I have to reset them everytime I want to use them, if I take them off they lose signal. It started with the last ios 16 update and after contacting apple, they said the airpods were with a late firmware version 5E135 and asked me to do some resets and update through mac and ios, to check if there was some trouble with the devices that could not update the airpods.

Since nothing worked they said they could do a replacement but since the warranty is past, they have to charge 330€ half the price of a new ones. So annoying and disapointing.

Really don't know what to do.
 
  • Like
Reactions: malreynolds

malreynolds

macrumors member
Jun 22, 2007
86
4
It happened to me as well. My APM were perfectly fine since day one, and out of nowhere I have to reset them everytime I want to use them, if I take them off they lose signal. It started with the last ios 16 update and after contacting apple, they said the airpods were with a late firmware version 5E135 and asked me to do some resets and update through mac and ios, to check if there was some trouble with the devices that could not update the airpods.

Since nothing worked they said they could do a replacement but since the warranty is past, they have to charge 330€ half the price of a new ones. So annoying and disapointing.

Really don't know what to do.
For me, the only thing I can do, reset every day. The most annoying and cheapest option.
 

josevazrodrigues

macrumors newbie
Sep 25, 2023
4
1
For me, the only thing I can do, reset every day. The most annoying and cheapest option.
Have some updates about my APM.

Yesterday I charged them up to 100% and kept them charging, tried A LOT of resets (staying longer pressing the buttons) and eventualy they started to lose connection less times. Also I tried to update them to the latest version, keeping them close to my phone, ipad, mac… even connected to the ipad… and… after some hours they got updated and now are running perfectly, like there were no issues… what makes me think this is something about apple updates… So my advice is trying to keep them updated and see if it gets back to normal.
 

Ryan P

macrumors 6502
Aug 6, 2010
362
235
Same issue here. Had to just do it twice today with iPhone 15 Pro Max. It just refuses to connect unless I factory reset them. No issues with Airpods Pro 2.
 

malreynolds

macrumors member
Jun 22, 2007
86
4
Same issue here. Had to just do it twice today with iPhone 15 Pro Max. It just refuses to connect unless I factory reset them. No issues with Airpods Pro 2.
Same, never had issues with my AirPods Pro 2 both lightning and usb c
 

SHates

macrumors member
Jun 13, 2012
36
7
Having the same issues. Really frustrating when you take them off and they refuse to connect only 5 minutes later.
 
  • Like
Reactions: Ryan P
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.