Anyones elses 27 waking randomly from sleep?

Discussion in 'iMac' started by C8XY, May 4, 2010.

  1. C8XY macrumors 6502

    Joined:
    May 11, 2008
    #1
    :confused:

    No attached USB devices, factory install of OS X with all the updates including firmware. Wireless keyboard up to date. Batteries nowhere near flat…

    Wake for network access yes but it shouldn’t be an issue as my old iMac worked perfectly with this feature?
     
  2. yargok macrumors newbie

    Joined:
    Jun 18, 2009
    #2
    I had the same issue - and it didn't go away until I disabled the wake on lan option.
     
  3. peteullo macrumors regular

    Joined:
    Dec 13, 2009
    Location:
    Scranton, PA
    #3
    I have noticed this also. Not very often but it does happen.
     
  4. RedReplicant macrumors 6502a

    Joined:
    Mar 31, 2010
    #4
    Yeah, it's really, really annoying. Wake for network access is turned off.
     
  5. slicecom macrumors 68020

    Joined:
    Aug 29, 2003
    Location:
    Toronto, Canada
  6. WilliamG macrumors G3

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #6
    I had never put my 27" to sleep, but mine started doing this, too. Figured out it was Bluetooth pulling it out of sleep. Go into Bluetooth options, and then "Advanced," and make sure the checkbox is unchecked for allowing BT devices to wake the computer.
     
  7. mikes63737 macrumors 65816

    Joined:
    Jul 26, 2005
    #7
    OP is using a wireless (bluetooth) keyboard and mouse. Disabling this would not allow the keyboard or mouse to wake the computer (at least this is how it works on my MBP).
     
  8. WilliamG macrumors G3

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #8
    You can still use the power button on the iMac to wake it up. With a MBP in clamshell mode it's a lot harder, for sure.
     
  9. mtnDewFTW macrumors 6502a

    Joined:
    Oct 26, 2009
    Location:
    San Francisco, CA
    #9
    This happened to me a few times, and then I disabled the option to wake up for network access and enabled put HDD to sleep when possible.

    Since them, I can't remember it ever waking up, or maybe I was just in deep sleep
     
  10. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #10
    Disabling the "Wake for Network Access" option in Energy Saver Preferences (System Preferences) should fix this problem.

    If not, try a PRAM and SMC reset.
     
  11. WilliamG macrumors G3

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #11

    Mine was already disabled when my iMac kept waking up. For me at least, it was the Bluetooth issue.
     
  12. C8XY thread starter macrumors 6502

    Joined:
    May 11, 2008
    #12
    :( I like this option as I have multiple computers I can access the iMac without manually waking

    Just done this, will see if it solves the problem. If not I’ll disable the bluetooth wake option and use the power button to see if this solves it.

    :apple:
     
  13. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #13
    Well, that's most likely the cause. Most people complain about it and disabling it fixes the problem most of the time.
     

Share This Page