Anyone's PUSH Mail not working

Discussion in 'iPhone' started by RonHC, Jun 29, 2010.

  1. RonHC macrumors 6502a

    RonHC

    Joined:
    Apr 27, 2010
    #1
    I have my Mail app to PUSH and so far, most of the time it wont push new email. i would have to manually go into the Mail App and wait for it to refresh

    Anyone?
     
  2. ki2594 macrumors 6502a

    Joined:
    Apr 12, 2008
    Location:
    Carmel, IN.
    #2
    yeah my Mobile Me hasn't been pushing since i upgraded to 4.0 on my 3GS (Getting my 4 next week)
     
  3. Goldinboy17 macrumors 65816

    Goldinboy17

    Joined:
    Jun 21, 2010
    Location:
    San Francisco, Ca
    #3
    I'm not using MobileMe to push my eMail. I added my eMail address manually since it's a personal one (my own domain). I am having problems with PUSH but figured maybe it's just because this isn't a normal GMail/Yahoo, etc. Not sure if it is or isn't normal, but yeah it does suck a little. I just had to set it to automatically refresh every 30 mins, although it makes the battery life worse.
     
  4. RonHC thread starter macrumors 6502a

    RonHC

    Joined:
    Apr 27, 2010
    #4
    i have Yahoo Mail and it doesn't push
     
  5. jl234 macrumors member

    Joined:
    Aug 24, 2006
    #5
  6. Syk macrumors 6502a

    Joined:
    Jun 20, 2010
  7. RonHC thread starter macrumors 6502a

    RonHC

    Joined:
    Apr 27, 2010
    #7
  8. veteq macrumors member

    Joined:
    Feb 6, 2008
    #8
    I had the same problem with Google mail. I recreated (deleted and created) the account and all started working again.
     
  9. coasterider macrumors regular

    Joined:
    Jun 29, 2010
    Location:
    Washington, DC
    #9
    EDIT: I found the fix. You have to set it up as an Exchange Server because GMail natively does not use Push Notification even though the option is there I guess. Here is a link to how to set it up
     
  10. RynoZebz macrumors regular

    Joined:
    Jul 12, 2008
    #10
    Yea, I found that work around but sadly it only seems to work for a couple days. Then I can receive emails but when I delete them it says they can't be moved to another folder and it stops the iPhone from deleting email or move anything around. It seems to only be able to receive messages. It sucks. After I delete the exchange account and put in all my info again it works flawless for a couple days again. My wife's new iPhone has the same problem. I used to use Yahoo Mail but just made the jump to GMail recently because I like it better. Any thoughts?
     
  11. mrfriggz macrumors member

    Joined:
    Feb 23, 2010
    #11
    I have email setup under Exchange, and I am not getting push. I did prior to upgrading to iOS4. I still have a 3gs so it isn't isolated to iPhone 4.

    It would be lovely to get a fix ASAP. I don't want to miss my reservation email :eek:
     
  12. dusters711 macrumors regular

    Joined:
    Aug 12, 2008
    #12
    My yahoo account was pushing after upgrade to 4.0 and even with my new iPhone 4 but the last 24 hours were a no go... My data has been out a lot as well (aka full bars and 3G but nothing)... I think I saw others on here with similar data issues!
     
  13. RonHC thread starter macrumors 6502a

    RonHC

    Joined:
    Apr 27, 2010
    #13
    yep i only have 1-2 bars while my Dad's 3GS has 3-4 bars in the same room
     
  14. Luminyx macrumors member

    Joined:
    Jun 25, 2010
    #14
    I was having this problem today and last night. It was working fine this weekend, but then I just stopped getting push notifications. I didn't get my three emails from last night and I noticed I wasn't getting two from today. I called up Apple, and the representative suggested I delete the account and readd it. It worked me for, although this will be a real nuisance if I have to continually delete and readd in order to get my push notifications.

    FYI, this problem was with my Yahoo email. Gmail did not face this problem. I have Fetch (15 minutes) on for Gmail and I still got those emails.
     
  15. rtztgue macrumors regular

    Joined:
    Aug 9, 2008
    #15
    similar problems

    Same thing here, my yahoo push does not work. Yahoo claims it is with the iphone and suggests deleting and adding again. That is a pain, Seems like apple needs to fix this.

    Anyone know if push is on AND fetch, will the fetch override the push and still get the mail? I will have to play with this.

    One thing that has changed and I do not know how to fix this, or re-work it. It used to be that when i got a new email my phone would show it as unread. If I checked it on my computer my phone would still show it as unread. No big deal, i would go to the phone and hit it real quick or delete it. no biggy. So now if i read it from my desktop, the phone will still show the message but it does not show up as unread, or even as a new mail. I dont get the mail notification. This is only a problem in one area. 2 of my mail accounts are general accounts for our company. so if you send an email to this account it goes to 5 recipients. But now, if any one of those recipients reads the email it will show as read on my phone. Not what I need. Anyone run into this, or know how to change the settings. It would be sweet to have both abilities. I dont mind it marking it read on my personal mail, but it needs to leave it as unread on the communal mail.
     

Share This Page