Anything needed to sync?

Discussion in 'iPod touch' started by Pangea, Nov 3, 2007.

  1. Pangea macrumors newbie

    Joined:
    Oct 31, 2007
    #1
    I bought my touch and when I plug it in it doesn't sync, it just says I need a service pack 2 and it also says its a camera. Any ideas on what to do?
     
  2. hecks macrumors regular

    Joined:
    Oct 27, 2007
    #2
    Install latest version of iTunes.
     
  3. kinchee87 macrumors regular

    kinchee87

    Joined:
    Jan 9, 2007
    Location:
    New Zealand
    #3
    If you're using Windows XP, then make sure you've got Service Pack 2 installed (SP2).
     

Share This Page