Anyway to disable bluetooth auto connect?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by kramerica2, Aug 11, 2014.

  1. kramerica2 macrumors regular

    Joined:
    Sep 15, 2009
    #1
    I have BT speakers at my living room, which I occasionally use to stream music to from my iPhone.

    Those speakers also serve as my TV speakers. Whenever I turn them on (to watch TV), my iPhone automatically connects to them, and while I can live with that, it automatically routes all audio to them.

    Is there anyway to change that default behavior? Either make it not connect automatically, or much better - let it connect but not route the audio by default.

    Right now, my only options are to either keep bluetooth on my iPhone off (and then I have to remember to turn it on in my car every time) or to unpair the speakers after using them (and then pair them every time I want to play some music).

    Am I missing something here, or is Apple missing something here?
     
  2. alanrocks macrumors regular

    alanrocks

    Joined:
    Nov 15, 2011
    Location:
    United Kingdom
    #2
    I don't think there is a way to do that I'm afraid. Maybe I'm wrong, but I'm not aware. Hopefully for you there is though!! :)
     
  3. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #3
    There's not even a jailbreak tweak that I know about that turns off auto-pairing per device. If there were, stock or jailbreak, you'd still have to go into settings to enable it when you want to use the speakers with your iPhone.

    Seems like the Bluetooth button in Control Center is easier than digging into settings and that's probably what Apple was thinking.
     
  4. anvienhponline macrumors newbie

    Joined:
    Aug 14, 2014
  5. Imac Sam macrumors 6502

    Imac Sam

    Joined:
    Oct 9, 2011
    Location:
    Harrisonburg, Virginia
    #5
    I also have the same issue. I pretty much try to remember to turn off bluetooth every time I enter the house. But sometimes I get home, forget to turn it off and then hours later wonder why my phone has been quiet all day. My speakers are a small pair that is kept in the bedroom for mood and sleep-time music. So I don't always hear the notifications when I am downstairs with the phone obviously.
     
  6. scrubmilk macrumors member

    scrubmilk

    Joined:
    Jul 18, 2014
  7. kramerica2 thread starter macrumors regular

    Joined:
    Sep 15, 2009
    #7
    Thanks everyone, I'm afraid this one is too annoying for me.

    I want to control which apps goes through bluetooth, I want to control auto connect, I want to control default behavior of Bluetooth. You know what? it should have been like that automatically. Who want's to hear his phone rings or notifications through BT speakers? Why should my phone route all the audio to every BT speaker it connects to? Even without control, the default behavior of the iPhone is flawed.

    I've been an iOS user ever since iPhone 3GS came out and made me switch from my Windows Mobile phone. My computers are all macs, my streamers are apple tv, you could probably put the Apple logo outside my door, since anybody that comes in might think it's an Apple store, but this issue could be the one to push me away to the other side.

    If iphone 6 / iOS 8 won't fix that issue, my next phone would probably be an Android. I'd only have to wait until someone makes a decent android phone....;)
     
  8. Markyyy macrumors regular

    Joined:
    Aug 1, 2013
    #8
    I'm dreading the time when I'll forget to 'Forget this device' and someone switches the bluetooth speaker on when I'm privately watching porn with myself in my bedroom on my iphone...:eek:
     
  9. Vanilla Face macrumors 6502

    Joined:
    Aug 11, 2013
    #9
    - Swipe up from the bottom to open control panel.
    - From there you can select what audio output you want to use.

    I'm not really sure what you want beyond that. You either need to tell the phone not to route to bluetooth, or have bluetooth on the phone off.
     
  10. kramerica2 thread starter macrumors regular

    Joined:
    Sep 15, 2009
    #10
    The request is quite simple - route specific audio through bluetooth, not all audio.
    Think of airplay for example. By default it only routes a certain video to the screen, and mirroring everything is an option. I want bluetooth to behave the same. ie - play music from the music app via bluetooth and every other sound - ringer, notification sounds, keyboard clicks, etc.. via the iphone speaker.
     
  11. Vanilla Face macrumors 6502

    Joined:
    Aug 11, 2013
    #11
    From what I can find, no operating system does that. I might be wrong as I didn't look too hard. If that's the case it might have something to do with the bluetooth profiles.

    It sounds like what you want to do is Airplay your music, so why don't you do that? You have the Apple TV hooked up to the TV and the speakers.
     
  12. TaddyKK macrumors newbie

    TaddyKK

    Joined:
    Oct 7, 2015
    #12
    I have a fix! The default behaviour for a device that has been paired and connected and then disconnected has to be to stay disconnected. Simple as that. It took some time and some strong language from my part, but the apple developer crew actually got back to me after six months with a fix.

    type

    sudo defaults write /Library/Preferences/com.apple.Bluetooth.plist DontPageAudioDevices 1

    in the Terminal. They claim it should work for OS X El Capitan 10.11 GM and beyond.

    I regged here just to let future googlers know, since I remember coming here with this problem way back.
     
  13. hodzy19 macrumors newbie

    Joined:
    Oct 15, 2015
    #13


    Has anybody tried this? Just wondering...
     
  14. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #14
    The original question was about an iPhone.
     
  15. rthorny macrumors newbie

    Joined:
    Dec 10, 2015
    #15

    Has anyone tried this?
     
  16. Trunks87 macrumors newbie

    Joined:
    Jul 2, 2012
    #16
    Thanks!
     
  17. andrewdavidmackenzie macrumors newbie

    andrewdavidmackenzie

    Joined:
    Feb 15, 2016
    #17
    sudo defaults write /Library/Preferences/com.apple.Bluetooth.plist DontPageAudioDevices 1
     
  18. jcbrown, May 12, 2016
    Last edited: May 12, 2016

    jcbrown macrumors newbie

    Joined:
    Aug 8, 2010
    Location:
    Driftwood, Texas, USA
    #18
    When my Android Phone does Bluetooth® Auto Connect with easyTek near my Mac, it causes my easyTek to Auto Connect with my Mac as well.

    Sequence •
    • Turn on easyTek -> Mac Bluetooth® Connects then Disconnects.
    • Android Phone sees easyTek -> Android Phone Bluetooth® Connects AND Mac Bluetooth® Connects.

    Terminal Command will not work 100%.

    Side Effect • If you turn on Bluetooth® on SmartPhone near Mac, SmartPhone will not connect to easyTek. easyTek has to be Connected to Mac before SmartPhone will Connect to easyTek.
     
  19. jagooch macrumors regular

    jagooch

    Joined:
    Jul 17, 2009
    Location:
    Denver, co
    #19
    Where do I type this on my iPhone? This thread is about an iPhone's Bluetooth functionality, which I'm sure you read carefully before posting.
     
  20. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #20
    Seems like just some posts from new users who posted once a year or so ago and never came back. Not really related to the topic at hand (as it has to do with iPhones), but not likely any of them really care as they haven't been back for quite a while.
     
  21. Cheezdog macrumors newbie

    Cheezdog

    Joined:
    Mar 6, 2017
    #21
    --- Post Merged, Mar 6, 2017 ---
     
  22. jagooch macrumors regular

    jagooch

    Joined:
    Jul 17, 2009
    Location:
    Denver, co
    #22
    Bump! This is still a problem, especially with AirPods. I can be listening to a podcast on my Sonos speakers, pick up the AirPods to put carry them to their case and put them in, and bam! the audio switches to my AirPods. I have to go find my phone to switch it back to output to the Sonos speakers.
     
  23. jon3543 macrumors 6502

    Joined:
    Sep 13, 2010
    #23
    It doesn't stick. That is, I can switch back to iPhone output, but the next time I power on my BT speakers, it automatically connects to them. Very aggravating indeed. Conversely, the Apple TV 4 is unable to auto-connect, and the setting is buried deep, though not as bad as the Fire TV Stick. Bluetooth is such a mess.
     
  24. Glassed Silver macrumors 68020

    Glassed Silver

    Joined:
    Mar 10, 2007
    Location:
    Kassel, Germany
    #24
    How is this still a thing?

    Does Apple use the stuff they make?

    AirPlay doesn't auto-route, so why does BT audio?

    Glassed Silver:ios
     

Share This Page