Anyway to restore build settings in my project?

Discussion in 'Mac Programming' started by robvas, Mar 1, 2012.

  1. robvas macrumors 68030

    Mar 29, 2009
    Using Xcode 4, I made a little project, nothing fancy just some basic UI stuff. I created it on a Lion machine. I had the folder on Dropbox, and the next day I built the project on an Snow Leopard machine. Seemed to run fine. It complained about 3 compiler settings but I changed those and it went okay.

    Now I am back on the Lion machine and the app won't even start, it just beachballs. I tried changing the settings back and it still doesn't work. Any clues before I just cut+paste the files into a new project and start all over?

    It crashes before loading, or loads then crashes when I click on a button. Xcode gives a logic error and then that's the end of that.

    The build settings were 'Deployment Target', 'Base SDK', and one other one. I forgot what it was.
  2. xStep macrumors 68000

    Jan 28, 2003
    Less lost in L.A.
    Perhaps try adding a new target. Then in the upper left of Xcode chose the new name from the popup list next to the stop button. You may have to edit the new build settings.

Share This Page