Apache 2 on Tiger Major Problem

Discussion in 'macOS' started by stevey500, May 26, 2005.

  1. stevey500 macrumors 6502

    Sep 8, 2004
    Salt Lake City, Utah
    Well I am having the same exact problem as this guy on this link here
    "My Apache 2 installation seems to have trouble serving large files,
    that is to say files larger than 100 kB or so. If I try to download
    the file, I get about 40-90k of it before the download stops. I've
    checked the access log, and it shows a 206 status code for the failed
    request: - - [04/May/2005:09:19:13 +0100] "GET
    /roger-stocks/merrytiller/english/english1.pdf HTTP/1.0" 206 418092

    I've tried requesting a large file from several computers both on the
    internet and over my network, but the result is the same. Even tried
    installing Apache 2 on my PowerBook (also running Tiger) and I still
    get this problem.

    I was using Apache 2.0.54 with PHP 5.0.4 quite successfully with OS X
    10.3.9 before I foolishly decided to do a fresh install of Tiger.

    I hope I've provided enough information. I couldn't find anything on
    Google, but perhaps I searched the wrong terms. Would anyone be kind
    enough to point me in the right direction?"

    I am having the same problem, It has been running fine till I installed tiger. I have PHP 5 installed and configured with apache along with MySQL. I need to get this running as soon as possible for a yearbook project at school. Thanks, any help is appreciated!
  2. jeremy.king macrumors 603


    Jul 23, 2002
    Fuquay Varina, NC
    According to http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html, Apache thinks that you requested only part of the file so it only delivered part of it. How are you requesting the file? How is it delivered? Content-types setup in httpd.conf? Are you using download accelerators? Have you tried other browsers?

    Seems to me it could be a variety of things...
  3. stevey500 thread starter macrumors 6502

    Sep 8, 2004
    Salt Lake City, Utah
    I am just hosting a standard Port 80 HTML and PHP website, windows machines, mac machines are accessing my server through web browsers... It worked perfectly fine before I upgraded to tiger... please someone help. On the client's side, say, internet explorer.. it will show all the thumbnails of a picture gallery( because they are under 100kb in size), but when you go to see the full size image ( over 400kb) it will only load about 1/5th of the jpg image, no matter where I am browsing from, locally (http://localhose) or through the internet, I get the same results...

Share This Page