Apache file share

Discussion in 'OS X Mavericks (10.9)' started by GokulKrish, May 10, 2014.

  1. GokulKrish macrumors newbie

    Joined:
    Apr 12, 2014
    Location:
    Chennai
    #1
    This may be very silly basic need. But advice :)

    I need to have files in "/Library/WebServer/Documents" shared when i type localhost in my web browser . I googled & did the following things

    sudo apachectl start

    Changed AllowOverride to all as follows in /etc/apache2/httpd.conf ::


    <Directory "/Library/WebServer/Documents">
    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    # Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important. Please see
    # http://httpd.apache.org/docs/2.2/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks MultiViews

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
    AllowOverride all

    #
    # Controls who can get stuff from this server.
    #
    Order allow,deny
    Allow from all

    </Directory>

    sudo apachectl restart


    But when i type localhost only thing I see is "It works!" not the files shared on that foldet.

    It sucks really . Please Help !!!!
     
  2. GokulKrish thread starter macrumors newbie

    Joined:
    Apr 12, 2014
    Location:
    Chennai
  3. unplugme71 macrumors 68030

    Joined:
    May 20, 2011
    Location:
    Earth
    #3
    Would be nice to post what you did to get it to work.
     
  4. GokulKrish thread starter macrumors newbie

    Joined:
    Apr 12, 2014
    Location:
    Chennai
    #4
    I did nothing great .

    After doing above mentioned steps , I just moved index.html.en file out of /Library/WebServer/Documents/ folder .

    Now share works great :) :apple:
     

Share This Page