Apache Permission issues

Discussion in 'Web Design and Development' started by PolyMe, Apr 2, 2009.

  1. PolyMe macrumors newbie

    Joined:
    Apr 2, 2009
    #1
    I have recently setup a ne Virtual Host on my Macbook, but when I try to view the site I get a 403 Forbidden message. The error log reports...

    "(13)Permission denied: /Users/me/Documents/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable"

    Virtual Host config...
    Code:
    <VirtualHost *:80>
    	ServerName trunk.chicaura.co.uk
    	DocumentRoot "/Users/me/Documents/company/clients/Client/2009-03 Initial Build/Website/trunk"
    </VirtualHost>
    
    There is no .htaccess file in the /Users/me/Documents folder, but I have also tried creating and copying one that works from another VHost. Still getting the same error. I have set the owner for Documents to me:_www which seems to work everywhere else.

    Can anyone help me with this? Why is it looking for an .htaccess file?

    Thanks,

    T
     
  2. PolyMe thread starter macrumors newbie

    Joined:
    Apr 2, 2009
    #3
    Sorted

    I worked it out in the end (not that I hadn't spent ages before posting this).

    It was because the site files were in my Documents folder, which the _www group does not have access to. Moved it elsewhere & it worked.

    Thanks for the response anyway.

    T
     

Share This Page