Apachectl issue

Discussion in 'Web Design and Development' started by pharrari, Dec 13, 2010.

  1. pharrari macrumors newbie

    Joined:
    Dec 13, 2010
    #1
    Hey guys I'm new here! So, here's the issue, I have Mac OSX 10.6.5 and I'm going through Lynda.com for learning how to do php and mysql. I ran into a brick when I tried to have the server restart by graceful and this error came up: /usr/sbin/apachectl: line 82: ulimit: open files: cannot modify limit: Invalid argument

    so I googled this and I ran into a fix that i was told to change the line from this: ULIMIT_MAX_FILES="ulimit -S -n `ulimit -H -n`" to this: ULIMIT_MAX_FILES="".

    Now after I did that when I try any of those commands: start,stop,graceful, it doesn't show anything, it just goes to the next line with no confirmation of stopping, starting, or restarting.

    What else needs to be done? Obviously this is Apples mess but I'm trying to fix it so I can follow along with the class I paid for.
     
  2. ct2k7 macrumors 603

    ct2k7

    Joined:
    Aug 29, 2008
    Location:
    London or Florida
    #2
    How did you get Apache: was it built from source, or prebuilt?
     
  3. pharrari thread starter macrumors newbie

    Joined:
    Dec 13, 2010
    #3
    dev.mysql.com
     
  4. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #4
    The fix you applied worked as it was supposed to. When 'apachectl graceful' etc. runs successfully, you're not supposed to get any feedback. The only feedback you would get would be an error message. You're not getting one, so you're good.
     
  5. pharrari thread starter macrumors newbie

    Joined:
    Dec 13, 2010
    #5
    Cool thanks! I was just going by the video and looks like maybe an earlier version showed some sort of confirmation when you typed in those commands so I only assumed something was funky. Thanks!
     

Share This Page