aperature import problems

Discussion in 'Digital Photography' started by Xzag, Jun 30, 2012.

  1. Xzag macrumors member

    Joined:
    Mar 19, 2012
    #1
    Hi all,

    I am consolidating several iPhoto libraries into one muther (sic) library with the new h/w I purchased. I have approx 950GB of iPhoto libraries, and one of them is 560GB. I have successfully imported 3 other libraries without issue, but on the 560GB one, Aperture is telling me that I do not have enough disk space, and that 19TB (yes, terabytes) are needed to transfer the library. Any idea how to get Aperture to overcome this roadblock?

    I have a new 2TB drive to house all the photos, and only 390BG are being used currently.

    The files currently are on HDD #1 (1TB), the library is on HDD #2 (2TB).

    any ideas?
     
  2. Xzag thread starter macrumors member

    Joined:
    Mar 19, 2012
    #2
    apparent fix

    Hi all,

    over the weekend, did a lot of playing on this. One of them caused A3 to break free, and import this library. My steps:

    1. Repaired the iphoto library
    2. repaired the permissions
    3. rebuilt about half of the thumbnails in iPhoto library (was increasing library size, so I stopped). This was taking forever anyway even with 12-core machine.
    4. imported one event as a project to a new A3 library
    5. imported above library into mother library
    6. rebuilt the iphoto library database (I think the last button)

    tried again to import the library to A3, and it was successful. Used the "add" function. I now have the entire 1.06TB of data in one A3 library (end goal).

    Will test files and such to make sure everything transferred, but on first inspection, this appears to have solved the issue. Hope this helps someone else with the same problem.

    ----------

    once I saw that this was going to import, I stopped it, and updated A3 with the latest release that came through over the weekend. I don't think that this solved it at all, as A3 was willing to import it without the update. In retrospect, this was a bad move....what if A3 had then declined this as a result of the update?....must have been tired.

    Now on to the clean up/back up, and eventual release of all these other machines from the HDD capture of so many libraries....
     

Share This Page