Aperture 2.1.2 crashing constantly, will not allow me to move library/ create vaults

Discussion in 'Mac Apps and Mac App Store' started by seenew, Apr 4, 2009.

  1. seenew macrumors 68000

    seenew

    Joined:
    Dec 1, 2005
    Location:
    Brooklyn
    #1
    Hi, I've searched for threads on this, but nothing came up with my particular situation. First, I'll state my specs

    iMac 24" (aluminum)
    3.06GHz Core2 Duo
    4GB RAM
    500GB HDD

    So, after much procrastinating, I decided this weekend that I would organize my photos better, and move my growing Aperture library off my internal drive in hopes of speeding up my recently lagging computer. I migrated from iPhoto to Aperture back in August of 2008 and have always been meaning to make a vault of all my old work and just store that offsite somewhere so I don't have to worry about the disk space or losing the files. But I never got around to it.

    So now my Aperture library is 35,000 photos large, and weighs in at 302GB.

    The first thing I tried to do (before I even knew Aperture was going to start crashing) was to move the Aperture Library file from its default location in the users/pictures folder to one of my external 1.5TB drives. However, the transfer would fail around 6GB in and say "some files could not be read or written." I tried several times to no avail.

    Giving up that route, I read around online and decided that I could just make a vault of my entire library on the external drive, then create a new library there, and restore from the vault.

    So I open Aperture to try and make a vault. It "unexpectedly quits" right when the interface loads. I tried again and got as far as naming the new vault, then it crashed again. Now it crashes even if I am trying to just view my images. I went on a short roadtrip with friends and got back last night, and it crashed halfway through the import of 400 images, but finished importing when I reopened it. I don't know if that's what started off the whole thing.

    Anyway, I noticed that I only had 4(!)GB of space left on my internal drive, so I did some quick cleaning and rearranging to external drives and freed up about 45GB of space. I figured that would give the app plenty of room to breathe.

    Nope. Still crashes.

    Rebooted several times, no help.
    Reset PRAM several times, nada.

    I am in real trouble here. I'm a photography student with three studio classes this quarter and I can't have this happening. I paid top dollar for this machine less than six months ago and now it's puttering along like it's 2 or 3 years old. When Aperture is open (when it would still work) the rest of the computer would just slow to a crawl. I have 4GB of RAM, why doesn't Aperture use more? I was reading that it would only use 1 or 2GB max. Why?
    But that part is not important.

    I need to get this fixed, so ANY help is GREATLY appreciated! I have the crash report saved from the last crash, so if anyone wants to see any part of it, let me know. It told me which thread caused the crash but it looked like generic usage stuff, nothing special (I was just trying to look at my trip photos).

    Thanks in advance,

    Screaming in Savannah
    (Chris)
     
  2. CyrusOz macrumors regular

    Joined:
    Mar 15, 2009
    #2
    don't get too excited about my reply mate - unfortunately it's nothing useful. I was just thinking that I am also a photographer and have made the change to Mac recently and was about to install Aperture (amongst other programs) but am now holding off until I hear some responses in relation to your post - better yet even a solution.

    I am already pissed off that many of my favourite plug-ins for Photoshop don't work on the Mac (i was a PC user until a few weeks ago and developed my own special way of post-processing images using certain plug-ins and actions) so I'm thinking that I made the wrong decision to go over to the Mac .... maybe I shot myself in the foot so to speak, but hopefully you get a decent answer to your problem and I'll be watching closely.

    Good luck mate.
    CyrusOz
     
  3. seenew thread starter macrumors 68000

    seenew

    Joined:
    Dec 1, 2005
    Location:
    Brooklyn
    #3
    So I got my hopes up really high and after clearing that 45GB off the internal drive and trying to move the library to the external once again, it got up to 265GB out of 302GB and then it stopped transferring with the error "some files could not be read or written" again. I even tried it again, this time using firewire and it got to 266GB then stopped.

    I don't know what to do.


    The program seems to be running in some capacity now (I can view photos). How can I make vaults of specific sets of images? Like I'd like to make one vault of all my work prior to summer of 2006, then vaults for each year following that period. If I did that, could I then delete those photos from the Aperture library making it more manageable?

    I don't understand, I thought Aperture could handle hundreds of thousands, if not millions of images. Why is it hiccuping with just 35,000?
     

Share This Page