Resolved Aperture 3.3 woes on updating library

Discussion in 'Mac Apps and Mac App Store' started by Prodo123, Jun 11, 2012.

  1. Prodo123, Jun 11, 2012
    Last edited: Jun 11, 2012

    Prodo123 macrumors 68020

    Prodo123

    Joined:
    Nov 18, 2010
    #1
    So my main photography library updated to the new unified library just fine.
    But when I tried to update the family photo archive, it got stuck at 99%.
    It's been like this for well over a hour now.
    Should I force quit Aperture? Or should I let it sit a little more?
    There's ~4000 photos in the archive, and I do have a backup of it on my Time Capsule.
     
  2. flynz4 macrumors 68040

    Joined:
    Aug 9, 2009
    Location:
    Portland, OR
    #2
    I am traveling and have not upgraded my library. I personally hate to force quit Aperture (or any program). I'd let it run overnight first.

    /Jim
     
  3. Prodo123 thread starter macrumors 68020

    Prodo123

    Joined:
    Nov 18, 2010
  4. ipedro macrumors 68040

    ipedro

    Joined:
    Nov 30, 2004
    Location:
    Toronto, ON
    #4
    Mine got stuck on step 6 so I force quit it. I tried again 3 times and it always failed at step 6. I tried to repair the library and it got stuck at a specific number of repaired photos. Then I tried to rebuild it. I left it over night and in the morning Aperture was open and Processing almost 100,000 photos (my entire Library?).

    Right now, many of my recent photos are missing. Zero photos -- no blank thumbnails either -- show in some of my Projects including one of my most recent. I still have the SD cards for that project. When I insert it and select skip duplicates, it doesn't show the photos so they must be in the Library.

    Right now the Activity says that it's Processing so I hold out hope that all my photos will be put back in their places once that's done. 78,000 to go. I guess I'm not working today...
     
  5. pmag macrumors newbie

    Joined:
    Jun 13, 2012
    #5
    pmag

    Mine got stuck at 99% on Step 10 and has been for 24 hours. I have about 9000 photos.

    I have restored my library from Time Machine once and still hangs at 99% on Step 10!!!

    Help - I have a magazine to complete.
     
  6. Wild-Bill macrumors 68030

    Wild-Bill

    Joined:
    Jan 10, 2007
    Location:
    bleep
    #6
    Wow, sorry to hear of these problems. Guess I should fancy myself lucky that Apple won't let me update since I'm still on Snow Leopard.
     
  7. guy curlewis macrumors member

    Joined:
    Jan 2, 2011
    #7
    Guess i am just lucky then

    Upgraded 5 libraries totalling 300gb in total with well over 100,000 images and all went smoothly.

    Love the zippier Aperture and the all grey interface is great as lets you look at colours of photos without interference!
     
  8. HLX macrumors newbie

    Joined:
    Sep 17, 2006
    #8
    From a previous crash and Aperture temporarily being up available to me, I was halfway through migrating my 130 GB of photos from iPhoto back into Aperture, event by event.

    This update just basically finished the job for me in one fell swoop. The merging process took about an hour, and the only fallout was a couple of duplicated events. Sweet.

    The unified library is excellent. I use Aperture but can now use the nicer book functionality of iPhoto without hassle.

    The unified library also points to a couple of things I think - namely an ongoing commitment to both apps as separate entities, and some upcoming iCloudy photo goodness that would prefer a more centralised photo base to point to.
     
  9. macmike47 macrumors regular

    Joined:
    Jan 8, 2007
    Location:
    On the road
    #9
    Mine's also just got stuck on 99% (step 10 of 10) while updating to 3.3. Grrr Apple. It's rather irksome when they put out buggy updates.
     
  10. macmike47 macrumors regular

    Joined:
    Jan 8, 2007
    Location:
    On the road
    #10
    I figured it out from a tip from a German Mac forum, I'll pass it on here in case anyone else was still having the issue (hanging at 99% on step 10 of 10, or step 7 of 7)

    Force quit Aperture, then open while holding Alt and Command. Choose "rebuild database". That's worked for me anyway.
     
  11. jordanogrady macrumors 6502

    Joined:
    Jan 31, 2010
    #11
    Has anyone solved this issue yet? I have force quit 3 times now, left it running for well over 2 hours, and its still on step 7 of 7 (98% complete) nothing seems to be happening!

    I know i changed from a macbookpro, to an iMac, and restored everything from a time capsule to initially set the mac up, could this be anything todo with it? Is it struggling to find some of the pictures or something? How can i get round this? It won't even let me open aperture at all now!

    Jordan

    ----------

    Currently trying this... thanks!

    Jordan
     
  12. jordanogrady macrumors 6502

    Joined:
    Jan 31, 2010
  13. pmag macrumors newbie

    Joined:
    Jun 13, 2012
    #13
    I have solved my problem by deleting Aperture 3.3 and restoring 3.2.3 from Time machine and then restoring my Aperture library as well.

    I then rebuilt my Aperture library in 3.2.3. This took only a couple of minutes for 10000 photos. (There was a problem with some of my photos which the rebuild process took care of).

    I then re-downloaded 3.3 and installed it and low and behold my library was upgraded within minutes and all is now OK :) :) :)

    What a relief!

    27" iMac 3.06GHz. Lion.
     
  14. Calixa macrumors newbie

    Joined:
    Oct 3, 2007
    #14
    Aperture 3.3 updating

    After hanging at 98% for hours this solution worked for me.
    Force Quit Aperture.
    Reboot holding the Command and Option keys down.
    Then rebuild the database. 6750 images took 10-minutes and it works like a charm!
     
  15. longtimelurker macrumors member

    longtimelurker

    Joined:
    Apr 28, 2011
    Location:
    Pacific NW
    #15
    the Aperture 3.3 update stuck at 98% fix

    Yep, and this is one of the reasons why MacRumors is invaluable. Thanks!!!

    :):)
     
  16. Mac In School macrumors 65816

    Joined:
    Jun 21, 2007
    #16
    I had the same problem. After force-quitting, holding down Command/Option while double-clicking the Aperture library file fixed it for me. Rebooting wasn't needed.
     
  17. jdag macrumors 6502a

    Joined:
    Jun 15, 2012
    #17
    Same for me.
     

Share This Page