Aperture 3 Deleting Question

Discussion in 'Digital Photography' started by claimed4all, Sep 25, 2011.

  1. claimed4all macrumors 6502

    Joined:
    Sep 26, 2008
    #1
    I have just moved my entire iphoto library to Aperture 3 (~10,000 photos). My library now resides in Aperture (I did not reference my iPhoto library).

    When browsing through picks I try to use the Command+Delete to delete photos, but its just gives me the idiot beep and does nothing, but I can right click a photo and select delete (and it does show the Command+Delete shortcut) How do I fix this, can I make it so just the delete key will delete a photo?
     
  2. flynz4 macrumors 68040

    Joined:
    Aug 9, 2009
    Location:
    Portland, OR
    #2
    I believe the philosophy behind A3 is to make it very resistant to accidental deletion of photos.

    My personal workflow has me almost never deleting any photos. Instead... I import them into projects, then stack, rate, etc... keeping everything. Then create as many albums or smart albums as I want (they take essentially zero space)... and within the albums, it is trivial to delete and add new pics (not masters... just versions).

    Given that storage space is essentially "free"... I just don't worry about deleting anything.

    /Jim
     
  3. MattSepeta macrumors 65816

    MattSepeta

    Joined:
    Jul 9, 2009
    Location:
    375th St. Y
    #3
    "9" sends them to the trash, where you can then "empty" the trash to delete them.

    Rather than deleting m no-t-the-best shots I simply do not rank them, then I view my keepers through a smart album only displaying ranked photos
     
  4. odinsride macrumors 65816

    odinsride

    Joined:
    Apr 11, 2007
    #4
    What view are you in while trying to delete pics?

    I usually rate all of my pics, and then using Filmstrip view, change the filter at the bottom right to only show me Rejects...then I select them all (in the film strip) and press command delete, it works every time.
     
  5. claimed4all thread starter macrumors 6502

    Joined:
    Sep 26, 2008
    #5
    Found out what I was doing. I was using the wrong delete key. I have the 10-key keyboard and kept trying to use the delete key next the the end key when you need to use the delete key about the enter key.
     

Share This Page