Aperture 3 Fails to Launch

Discussion in 'Mac Apps and Mac App Store' started by mikeherdes, Jan 31, 2011.

  1. mikeherdes macrumors member

    Joined:
    Jan 29, 2010
    #1
    I've been trying for the last two days to fix Aperture 3 on my Macbook Pro, but I'm having no luck.

    Here is the error I get:


    cess: Aperture [665]
    Path: /Applications/Aperture.app/Contents/MacOS/Aperture
    Identifier: com.apple.Aperture
    Version: ??? (???)
    Build Info: Aperture-1290000~2
    Code Type: X86-64 (Native)
    Parent Process: launchd [141]

    Date/Time: 2011-01-31 22:16:53.916 -0800
    OS Version: Mac OS X 10.6.6 (10J567)
    Report Version: 6

    Interval Since Last Report: 381094 sec
    Crashes Since Last Report: 27
    Per-App Crashes Since Last Report: 23
    Anonymous UUID: D1A977B0-79D9-4427-9BA0-1408EF63258C

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread: 0

    Dyld Error Message:
    Library not loaded: /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager
    Referenced from: /Applications/Aperture.app/Contents/MacOS/Aperture
    Reason: no suitable image found. Did find:
    /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager: no matching architecture in universal wrapper

    Binary Images:
    0x7fff5fc00000 - 0x7fff5fc3bdef dyld 132.1 (???) <B536F2F1-9DF1-3B6C-1C2C-9075EA219A06> /usr/lib/dyld

    Model: MacBookPro5,5, BootROM MBP55.00AC.B03, 2 processors, Intel Core 2 Duo, 2.26 GHz, 4 GB, SMC 1.47f2
    Graphics: NVIDIA GeForce 9400M, NVIDIA GeForce 9400M, PCI, 256 MB
    Memory Module: global_name
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (5.10.131.36.1)
    Bluetooth: Version 2.3.8f7, 2 service, 19 devices, 1 incoming serial ports
    Serial ATA Device: ST95005620AS, 465.76 GB
    Serial ATA Device: HL-DT-ST DVDRW GS23N
    USB Device: Built-in iSight, 0x05ac (Apple Inc.), 0x8507, 0x24400000
    USB Device: Internal Memory Card Reader, 0x05ac (Apple Inc.), 0x8403, 0x26500000
    USB Device: Apple Internal Keyboard / Trackpad, 0x05ac (Apple Inc.), 0x0236, 0x04600000
    USB Device: IR Receiver, 0x05ac (Apple Inc.), 0x8242, 0x04500000
    USB Device: BRCM2046 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x06100000
    USB Device: Bluetooth USB Host Controller, 0x05ac (Apple Inc.), 0x8213, 0x06110000

    ------------
    I've tried reinstalling the program multiple times with no luck, restoring my computer from a time machine back up, and I've tried replacing the apple prokit files.

    I really need to get this working again. Any help would be appreciated.

    Thanks
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Does the same happen with another, temporarily created, user account?
    Have you tried a normal reinstallation of Mac OS X yet, without the use of Time Machine?
    Do you still have Apple Care?
     
  3. psxguru macrumors 6502a

    Joined:
    May 19, 2006
  4. mikeherdes thread starter macrumors member

    Joined:
    Jan 29, 2010
    #4
    Thanks for the replies. I can't get past the error screen (no part of Aperture opens).


    I don't have apple care, but I'll try creating another account. I haven't tried a full reinstall because of the time that would require, but it's starting to look like I may have no choice.
     
  5. mikeherdes thread starter macrumors member

    Joined:
    Jan 29, 2010
    #5
    Creating another user account does not work....

    I'll send anyone $20 CND though paypal if they find a way to fix it without reinstalling os x.
     
  6. RedRaven571 macrumors 65816

    RedRaven571

    Joined:
    Mar 13, 2009
    Location:
    Pennsylvania
    #6
    I was having same problem with iPhoto, found a solution that worked for me.

    According to this Apple forum,
    http://discussions.apple.com/message.jspa?messageID=12892306


    the same solution may work for you.

    System Preferences > Spotlight > Security

    Add your Bootcamp volume to the Security section (either by clicking '+' and selecting the partition; or just drag the volume icon into the Security section)

    Then try launching A3 and see what happens. Apparently there is some issue with Spotlight, Bootcamp and 10.6.6.

    Good luck!

    PS - if it works, keep your $20; just happy to help if I did.
     
  7. mikeherdes, Feb 1, 2011
    Last edited: Feb 1, 2011

    mikeherdes thread starter macrumors member

    Joined:
    Jan 29, 2010
    #7
    Thanks for the suggestion, unfortunately it didn't work. I even deleted the entire boot camp partition and still had no luck.

    Edit:
    Turns out it's a simple fix.

    For those with the same problem:
    1. Navigate to: /Library/Frameworks/PluginManager.framework/Versions/B/PluginManager
    2. Delete the PluginManager
    3. Get a new copy of the PluginManager. (You can copy one from a friends macbook) or use the one hosted here: http://qvenon.com/files/PluginManager.zip

    Thanks to those who offered help.
     
  8. mrreillyb macrumors newbie

    Joined:
    Mar 22, 2011
    #8
    The above fixed worked for me! I have spent a week crawling through forums and trying everything, and this was the fix, thank you!!
     
  9. PHST macrumors newbie

    Joined:
    May 21, 2011
    Location:
    Rotterdam, The Netherlands
    #9
    Aperture 3 Fails to Launch

    Same problem occured to me after updating the App version of Aperture to 3.1.2. Your solution worked! Thank you.
     

Share This Page