Aperture and Nik HDR Plugin

Discussion in 'Digital Photography' started by LongSticks, Oct 5, 2013.

  1. LongSticks, Oct 5, 2013
    Last edited: Oct 5, 2013

    LongSticks macrumors 6502

    Joined:
    Jul 22, 2012
    Location:
    Kent, UK
    #1
    I have had a quick search through the Forum for anyone else having this issue and cant find it.

    I have Aperture with Nik Plugins. Everything works fine apart from HDR Efex. Every time I launch it from Aperture, it crashes Aperture completely and I get the the Apple Crash report.

    Is anybody else having the same problem?

    Current software versions are

    Process: Aperture [314]
    Path: /Applications/Aperture.app/Contents/MacOS/Aperture
    Identifier: com.apple.Aperture
    Version: 3.4.5 (3.4.5)
    Build Info: Aperture-320090000000000~1
    Code Type: X86-64 (Native)
    Parent Process: launchd [159]
    User ID: 503

    PlugIn Path: /Library/Application Support/Aperture/*/HDR Efex Pro 2
    PlugIn Identifier: com.niksoftware.hdr2.aperture-edit
    PlugIn Version: 2.003 (2.003)

    Date/Time: 2013-10-05 09:59:42.417 +0100
    OS Version: Mac OS X 10.8.5 (12F37)
    Report Version: 10

    Also if I try and run HDR Efex natively, I get the screen shot below. I have checked the Nik website but cant find any way to see if theres an update fix, as its all changed to a Google site. The error message won't let me check for updates through preferences as it closes automatically. I have tried re-installing to no avail.

    Any ideas or work arounds?

    *I have tried the Font Book Arial solution from drsquibb and this has not helped!!*
     

    Attached Files:

  2. schmick63 macrumors newbie

    Joined:
    Feb 18, 2013
    #2
    Yes - same problem here - noticed a week ago and have not found a solution
     
  3. Padaung macrumors 6502

    Padaung

    Joined:
    Jan 22, 2007
    Location:
    UK
    #3
    Wow, just tried to use HDR Efex Pro 2 and it happened to me too - totally crashed Aperture. Thankfully I use the plug-in very infrequently, but it is very annoying to have a piece of software that I've paid full price for (before Google bought Nik and lowered the price!) crashing programs on my computer.

    I'm using a Mac Mini 2012 running OS 10.8.5 with 10Gb RAM. I only got this computer 6 weeks go and the plug-in worked fine on my old lMacbook running OS 10.6 with 4Gb RAM.
     
  4. NeGRit0 macrumors 6502a

    NeGRit0

    Joined:
    Apr 19, 2008
    Location:
    Las Vegas, Nv
    #4
    Works fine for me. Created this just now from a random set of RAWs in my Aperture catalog.
     

    Attached Files:

  5. Padaung macrumors 6502

    Padaung

    Joined:
    Jan 22, 2007
    Location:
    UK
    #5
    Just heard back from Nik customer support.

    They asked me to confirm my purchase (as I had hadn't bothered to register my copy) and they would then send me a download link for the latest version of the plugin - I'm still using the original version of the plugin from before Google bought the company. I guess that the plugin may also have been updated for increased compatibility with Mountain Lion since I first installed it a year ago too.

    Fingers crossed!
     
  6. LongSticks thread starter macrumors 6502

    Joined:
    Jul 22, 2012
    Location:
    Kent, UK
    #6
    Me too!

    Did the same thing, confirmed purchase yesterday and the link came through this morning from Nik. Won't be able to reinstall till tomorrow, but will post result. :rolleyes:l

    From what I've read elsewhere it appears it might be the Aperture update that caused the problem. What's the betting we get it sorted and the Aperture X appears at the end of the month and breaks it again!
     
  7. flynz4 macrumors 68040

    Joined:
    Aug 9, 2009
    Location:
    Portland, OR
    #7
    After Google bought NIK, I had read that all current customers of the suite would be automatically given a "purchase" of the new Nik suite. After waiting several months without being contacted... I wrote to customer service and they sent me the link for the latest version.

    I have had zero issues with the software.

    /Jim
     
  8. Padaung macrumors 6502

    Padaung

    Joined:
    Jan 22, 2007
    Location:
    UK
    #8

    Yeah, I didn't receive any contact either after the change to Google ownership.

    Anyway, I received the download link from Nik customer service earlier today, updates are now installed and all is working fine again :)

    Great of them to include the plugin for Aperture, Lightroom and Photoshop - something Nik used to charge double for (which I refused to pay, so previously made do with the suite just in Aperture).
     
  9. LongSticks thread starter macrumors 6502

    Joined:
    Jul 22, 2012
    Location:
    Kent, UK
    #9
    Same as....

    I can report the same.....Google are standing by the original software agreement! All sorted.
     

Share This Page