Aperture - how to share photos with two users

Discussion in 'Digital Photography' started by Viljami, May 30, 2009.

  1. Viljami macrumors newbie

    Joined:
    Dec 7, 2008
    #1
    We have two users with separate log ins for our MB Pro (me and my wife). I have continued to use Aperture after the trial period, and the said library is still called "Aperture Trial Library", which is ok as everything works well.

    My challenge is to arrange Aperture available also for my wife when she logs in to the computer with her own password. I tried to do it so that I moved the file Aperture Trial Library from my own Photo file to Public folder (common for all users). At my own side I then just redefined this location from Preferences, and everything works well. However, when I tried to do the same for my wife, I get a notice telling that this file is "unwritable", and it cannot be chosen (i.e. no photos can be seen). What should I do to get Aperture to work exactly in same way whether used with my or my wife´s log ins? Do I need to move the software as well to the public folder or use certain alias tricks?
     
  2. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #2
    Personally, I'd move it to /Users/Shared, and right-click > Get Info on it and make sure the permissions were set so tat everyone can Read & Write.
     
  3. Viljami thread starter macrumors newbie

    Joined:
    Dec 7, 2008
    #3
    Thanks, I did this and now this Aperture Trial Library can be selected without any failure notice. However, there are still no photos available in Aperture when opened with my wife´s log ins. Any ideas?
     
  4. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #4
    If she double-clicks on a blank image, does the picture show up then? I'm wondering if Aperture keeps some of the previews and stuff in the local profile area? I know Aperture has the ability to rebuild previews and stuff, just not sure if that'd help the situation for her.
     
  5. Viljami thread starter macrumors newbie

    Joined:
    Dec 7, 2008
    #5
    There is nothing on my wife´s side: no projects and no single photo. So I am sorry but I do not get your point when you recommend to "double-click on a blank image".
     
  6. cosmokanga2 macrumors 6502a

    cosmokanga2

    Joined:
    Jan 7, 2008
    Location:
    Canada, where we live in igloos.
    #6
    When you view the actual Aperture Library file, what is the size it shows and the number of files? Seems like it is not connecting somehow to the library file.
     
  7. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #7
    After having moved my Aperture library, I opened it up and saw no photos. My folders, projects, etc were all there, but were the photos would be were blank frames. And if you double-clicked a blank frame, the photo would appear. I didn't understand that when you said your wife couldn't see the photos, that she couldn't also see the projects, albums, etc.

    I'm with cosmokanga2. It doesn't sound like she's opening up the same Aperture library that your profile is. If she holds the OPTION key down while launching Aperture, maybe check to see that it's pointing to the one in /Users/Shared. If that still doesn't work, the only other thing I can think is to use Finder and check the file permissions again and make sure "everyone" has "read and write" access.

    If worse comes to worse, do you have an external drive you can copy the library to? Both of your profiles should be able to read and write from there without having to worry about disk permissions.
     
  8. Viljami thread starter macrumors newbie

    Joined:
    Dec 7, 2008
    #8
    None of these help, and I am actually inclined to believe that Aperture cannot be properly used by different users as I also googled few articles who claim the same. I just though if there are some Aperture users around here who have overcome this problem, but apparently not. I think I will arrange it so that my wife can look at the photos via iPhoto (using Aperture library). Hopefully this will work out.
     
  9. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #9
    I just moved my Aperture library to /Users/Shared, changed the permissions (which took a huge amount of time, where it looked like it was done, but watching the Activity Monitor, it actually took 10 minutes), created a new test user, logged on as the user, and then opened the Apeture library in /User/Shared.

    It worked. I saw all projects/folders/etc, and all of the photos showed up.

    The only issue I had was that it initially wouldn't open because the change permissions hadn't finished. (I used the fast logon switching, so when I logged on as the test user, it didn't log my other account off, which was still running the permission change). I let that finish and it worked OK.

    Hopefully your iPhoto workaround will work for you.
     

Share This Page