Aperture not deleting photos

Discussion in 'Digital Photography' started by mynewromantica, Jul 20, 2010.

  1. mynewromantica macrumors regular

    Joined:
    Aug 3, 2009
    #1
    I am running out space on all of my HD's so I started going through the many aperture libraries and deleting old, useless and bad photos. I had one 214 GB Aperture Library that after deleting, most of the photos from it within aperture, it still is at 214 GB. They do not show up anywhere in Aperture. I checked the library package and they are still there. How do I get them to delete properly the FIRST time?
     
  2. OreoCookie macrumors 68030

    Joined:
    Apr 14, 2001
    Location:
    Sendai, Japan
    #2
    The question is how you delete them and how you're managing your photos. You can mark photos for deletion (by giving them a special rating marked with x instead of stars), but that doesn't delete your photos right away. Then, you can focus your selection on all pictures marked for deletion. If you now select them and hit Alt + Backspace, you really delete them for good.

    It's supposed to work this way as it gives you a possibility to review your decision to delete the pictures you have marked for deletion.
     
  3. mynewromantica thread starter macrumors regular

    Joined:
    Aug 3, 2009
    #3
    I have tried it 2 different ways: select photos, right click, select delete. And select photos, command-backspace.

    Neither worked properly.
     
  4. Designer Dale macrumors 68040

    Designer Dale

    Joined:
    Mar 25, 2009
    Location:
    Folding space
    #4
    Have you tried selecting the Aperture Trash in the sidebar and emptying it?

    Dale
     
  5. mynewromantica thread starter macrumors regular

    Joined:
    Aug 3, 2009
    #5
    Dear Lord! That was it. I did not know Aperture had a Trash can.
    Thank you.
     
  6. mtbdudex macrumors 68000

    mtbdudex

    Joined:
    Aug 28, 2007
    Location:
    SE Michigan
    #6
    and after you empty the trash in aperture its moved to your MacOS trash, so 1 last time to keep or delete.....
     

Share This Page