Aperture really slow in OSX 10.10

Discussion in 'OS X Yosemite (10.10)' started by beachmusic, Sep 21, 2014.

  1. beachmusic macrumors regular

    beachmusic

    Joined:
    Jan 12, 2013
    Location:
    St. George Island
    #1
    Like the title says Aperture is really slow opening in 10.10. I get the spinning wheel for 30 to 45 sec before it settles down. Sometimes as much as 2 min. Anything I can do to fix this?
     
  2. TallGuyGT macrumors regular

    TallGuyGT

    Joined:
    Aug 8, 2011
    Location:
    NYC
    #2
    Sorry I don't have a fix for your problem, but did want to let you know (if you weren't already aware) that Apple has discontinued further development of Aperture. They did commit to compatibility fixes for Yosemite, which I expect to be out after the official release of Yosemite. May be time to look for an alternative. :(
     
  3. beachmusic thread starter macrumors regular

    beachmusic

    Joined:
    Jan 12, 2013
    Location:
    St. George Island
    #3
    I already new that but thanks for taking the time anyway. Right now I just keep it shrunk down and open all the time.
     
  4. Montymitch macrumors regular

    Montymitch

    Joined:
    Feb 16, 2009
    #4
    I don't have an answer for you, but a question. What hardware are you using? I use Aperture daily with my 2010 MBP, and I'm worried that Yosemite is going to put a nail in it's coffin.
     
  5. beachmusic thread starter macrumors regular

    beachmusic

    Joined:
    Jan 12, 2013
    Location:
    St. George Island
  6. TallGuyGT macrumors regular

    TallGuyGT

    Joined:
    Aug 8, 2011
    Location:
    NYC
    #6
    Are you guys looking at alternatives? I wish Apple would publish more info on Photos for Mac coming early next year.

    Photoshop/Lightroom seems like too much for my needs, and I think I'd miss iCloud integration.
     

Share This Page