Aperture says "Volume offline" when it's not. No luck fixing!

Discussion in 'Digital Photography' started by Works4Me, Aug 9, 2011.

  1. Works4Me macrumors regular

    Aug 29, 2007
    After a crash and restore last week (latest version of Aperture and, of course, Lion), all my projects and albums in Aperture show up, but there are nor previews, and when I try to locate the referenced files (all stored in their locations on the drive - not the Aperture library) I get the following message:

    "The selected master images are either offline or not found. Please reconnect them and try again." The images in question are still whey they should be....

    I tried selecting the "Locate Referenced Files" command under the "File" menu. But when I navigate to the images I want to reconnect, the reconnect options in the "Referenced Files in Selection" window are greyed out and I really have no idea how to fix the problem.

    Oh and I tried Apple's other "try this to see if it works" troubleshooting tips to no avail.

    Any help would be very much appreciated!

  2. mousemd macrumors member

    Nov 21, 2002
    I have personally had the same experience not that long ago. You should look back at the post I placed about a month or so ago re: a very similar experience. In either case, the first question that should be asked is: was it referenced or managed? If it it was referenced, then the folders/photos should still be there intact. If the photos are there, then you should be able to rebuilt the libary. Worse case scenario, you could always re-import those photos. I unfortunately had a managed library (my bad). No more Aperture for me now...

    Good luck!

  3. Works4Me thread starter macrumors regular

    Aug 29, 2007
    Thanks for the reply. Aperture really is a "bag of hurt" in this regard. After the crash and restore, LightRoom 3 worked perfectly!

    I was able to figure how to reconnect all the "missing" files, but I really stumbled on the way to get it to work by sheer luck. If anyone's interested, I'll post how (and display my lack of Aperture savvy for everyone) :)
  4. dgshields917 macrumors newbie

    Aug 23, 2011
    Please post solution suffering from same problem

    I have the exact same problem that Aperture thinks the volume is not mounted but it is and it also says that it can find the files but no preview image and no ability to for Aperture to find files via Finder. Please post your solution, I have been stumbling about now off and on for four days.:confused:
  5. Works4Me thread starter macrumors regular

    Aug 29, 2007
    I followed the instructions here:


    BUT, the trick for me was that I had to select ALL files in whatever project I was in, then I had to make sure I navigated to the folder with the file in the list. The "Reconnect" or "Reconnect All" option won't be active until you select a single file in the folder you've navigated to (from the lower left hand menu) that matches whatever file you've selected from the list in the middle top panel. Then you hit "reconnect all" and it usually works. You also have to update previews to see that it's worked....

    Man, I hope that helps. There's probably better ways of doing this, but other than re-importing files it's the simplest. The good thing is, you can do multiple projects at once....
  6. vinnie110 macrumors newbie

    Nov 25, 2008
    Aperture say my Macintosh HD is offline

    Relocating Masters doesn't work for me as it doesn't show photos as missing but that the volume is offline. The volume been my Macintosh HD. Funny as I'm running my MBP so it must be there.

    Any thoughts on this?

Share This Page