Aperture Sliders only sometimes Laggy?

Discussion in 'Digital Photography' started by sukanas, Nov 9, 2009.

  1. sukanas macrumors 6502a

    sukanas

    Joined:
    Nov 15, 2007
    #1
    when I edit raw pics in aperture, the sliders sometime get SUPER laggy and irresponsive. could it be the pictures creating previews? oh and 90% of the time the sliders dont lag at all
     
  2. Phrasikleia macrumors 601

    Phrasikleia

    Joined:
    Feb 24, 2008
    Location:
    Over there------->
    #2
    One of my many complaints about Aperture. I get that sluggishness more often than not now that my Aperture library is quite large. But yes, if the program is rendering previews, it will be even worse.
     
  3. Doylem macrumors 68040

    Doylem

    Joined:
    Dec 30, 2006
    Location:
    Wherever I hang my hat...
    #3
    While Aperture is creating previews I don't do any editing at all (it would be too frustrating... with the time-lag). I guess it's the downside of having a big collection of pix... :(
     
  4. sukanas thread starter macrumors 6502a

    sukanas

    Joined:
    Nov 15, 2007
    #4
    so to avoid the sluggishness, should I wait for ALL the previews to completion?
     
  5. iTiki macrumors 6502

    Joined:
    Feb 9, 2007
    Location:
    Maui, Hawaii
    #5
    Thats what I do.
     
  6. Edge100 macrumors 68000

    Joined:
    May 14, 2002
    Location:
    Where am I???
    #6
    To avoid the sluggishness, I use Lightroom....

    [ducks]
     

Share This Page