"api.mybrowserbar.com" - Virus/Malware help?

Discussion in 'Mac Basics and Help' started by oneinten, Dec 6, 2013.

  1. oneinten macrumors member

    Joined:
    Mar 16, 2013
    #1
    Hello,

    I use my Mac mini concurred to a wireless router that our downstairs Windows PC is hardwired into. This morning both computers connected to the internet fine and then out connection went down, the PC downstairs wouldn't connect so obviously my Mac wouldn't connect either after this.

    I started to look at my Chrome browser and noticed that the URL automatically redirects to "api.mybrowserbar.XXXX" (XXXX being the original intended URL)

    I looked into this on my phone and apparently it's a malware/virus and I have no idea how to get rid of it on my Mac, would a time machine restore help? Also, it may be coincidence that our internet connection has gone down but could this virus/Malware be affecting the PC as well and could it cause this kind of failure?

    Any help/advice would be greatly appreciated, I need to make sure both computers and the network are safe!
     
  2. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #2
    Try booting in to Safe Mode and see if the problem persists. To boot in to Safe Mode, do the following:

    1. Shut down your Mac.
    2. Hold the Shift key while powering up. Continue to hold the Shift key until after you see the Apple logo.

    *Note: Safe Mode will boot a bit slower.

    Also, try checking your DNS (System Preferences/Network) to make sure it hasn't changed.
     
  3. oneinten thread starter macrumors member

    Joined:
    Mar 16, 2013
    #3
    I'm not sure what my DNS settings were before.. is there a way to check when my DNS settings should be?
     
  4. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #4
    Your ISP should provide that or it can be pointed at your router. Or, you can set it to a free DNS service like OpenDNS.
     
  5. Tumbleweed666 macrumors 68000

    Tumbleweed666

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #5
    Remove /disable all the extensions from your browser.
    Did you recently install vuse?
     

Share This Page