Apogee Duet 2 possible on 10.6.4

Discussion in 'Digital Audio' started by Tijs, Jan 19, 2012.

  1. Tijs macrumors newbie

    Joined:
    Jan 19, 2012
    #1
    Hello I'm new here on this forum and I was wondering if anyone here knows if the Apogee Duet 2 will run on 10.6.4.
    I want to pick that up this weekend but when I looked at their site today it said 10.6.8 as a minimum requirement.

    I'm pretty sure that 10.6.4 was also supported when it was released. Is it still possible to get those older drivers and use them (couldn't find them on apogees site)? I really don't want to upgrade right now.

    Any help would be appreciated.
     
  2. Tijs thread starter macrumors newbie

    Joined:
    Jan 19, 2012
    #2
    Solved. Apogee support sended me a 10.6.4 compatible installer.
     

Share This Page