Apogee Duet Firewire on OSX 10.6.8

Discussion in 'Mac Basics and Help' started by Rufio90210, Apr 22, 2012.

  1. Rufio90210 macrumors newbie

    Joined:
    Apr 22, 2012
    #1
    Hello there

    I have a late 2008 macbook with logic 9, trying to hook up the apogee duet i just bought but says not compatible with 10.6

    Have searched online and can't seem to find anything to download to make this happen, surely there must be? Can anyone help me out?

    Rufio
     
  2. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #2
    I did a simple google of this thread's title:
    Apogee Duet Firewire on OSX 10.6.8

    Found this page:
    http://www.apogeedigital.com/downloads.php

    Find Duet Firewire under Legacy Products.

    The download labeled "Duet FireWire Software Installer Mac OS X Lion" says "Not compatible with Snow Leopard OS 10.6". Ignore that one.

    The one directly below it, labeled "Previous Duet FireWire Software Installer" says "Compatible with OS 10.5.8 thru OS 10.6.8". Try that one.
     

Share This Page