Apostrophe needs space

Discussion in 'macOS' started by tezro, Apr 7, 2011.

  1. tezro macrumors regular

    tezro

    Joined:
    Sep 7, 2007
    #1
    I play World of Warcraft, and I got a problem with my Apostrophe key.
    For some reason, my Mac Pro want me to press space every time I press the ' (Apostrophe) key. Either as a single character, or in a word-combo like "you're".
    So, when I type you and press ' that character is selected. Normally you would just type on, but if I do that then the ' is gone. So I have to press space before typing re.

    Oddly, typing this post right now and pressing ' also selects the character, and I have to press space twice to exit the selection of the character, and get a space. But when typing "you're" I can at least continue typing.

    On my MacBook Pro I don't have this problem at all, and it's also not related to the keyboard I use. And several keyboards I've tested so far.
    I checked the keyboard settings but can not find anything related, as far as I know.

    Can anyone help me with this? It's really starting to annoy me by now.
     
  2. DHKaplan macrumors member

    Joined:
    Jul 10, 2008
    #2
    This could be a really simple problem...

    Go to System Preferences, Personal, Language & Text, Input Sources.

    On the bottom you should click "Show Input Menu in Menu Bar"

    Then you should see a USA flag. If you do see that flag, the problem is something else. If you don't see it, click on the flag and click on US. If you have US-International PC checked that will give you the accents that are on foreign languages (and some words we use all the time like café)

    The apostrophe turns into an accent if you type ' followed directly by certain letters depending upon the language.

    Hope this is your problem..

    DHK
     
  3. tezro thread starter macrumors regular

    tezro

    Joined:
    Sep 7, 2007
    #3
    In the past I have looked in that direction, but perhaps not the input method.
    Will check it tonight when I get back home.

    Here in the MBP it's set to Dutch. All US input methods are disabled it seems.
    So I will try Dutch on the MP as well.

    Thanks so far, will update when I get back.
     
  4. tezro thread starter macrumors regular

    tezro

    Joined:
    Sep 7, 2007
    #4
    The problem was the US International flag.
    Set it too Dutch like on my MBP, and now I can type " and ' without problems again.

    Thanks for the help!
     

Share This Page