Apostrophe reduces SMS limit to 70 characters

Paul_W

macrumors member
Original poster
Jun 8, 2016
72
34
Rutland, UK
Does this happen to anyone else? When I type an SMS on my iPhone I get the usual 160 character limit. But as soon as I type an apostrophe the limit is reduced to just 70. I'm sure this never used to be the case. I've only noticed it since installing iOS 11 (although I rarely send SMS these days as everyone is on whatsapp).

Any ideas?
 

NoBoMac

Moderator
Staff member
Jul 1, 2014
2,836
1,158
My device is doing the same. However, I sent a test text message and it appears to have sent a 97 character text as one message. Counter kept ticking up past the changed 70 character limit.

Appears to be a UI bug, not affecting actual usage.
 

Paul_W

macrumors member
Original poster
Jun 8, 2016
72
34
Rutland, UK
At least it’s not just me then. Looks like just a bug with the counter. How do you go about reporting these things to Apple?
 

Dave-Z

macrumors 6502a
Jun 26, 2012
808
1,322
I don't know if this will fix it, but if I had to guess it has to do with using multibyte characters. Try turning off "Smart Punctuation" (introduced in iOS 11) in Settings > General > Keyboard and see if that changes anything.
 

NoBoMac

Moderator
Staff member
Jul 1, 2014
2,836
1,158
I don't know if this will fix it, but if I had to guess it has to do with using multibyte characters. Try turning off "Smart Punctuation" (introduced in iOS 11) in Settings > General > Keyboard and see if that changes anything.
Yes, that seems to be the case. Turning that off keeps the max character count at 160 (ie. Non-Unicode) when entering quote/apostrophe.
 
Last edited:
  • Like
Reactions: kandasmom

mpavilion

macrumors 6502a
Aug 4, 2014
960
562
SFV, CA, USA
Only very tangentially related — I think it’s cool that typing two hyphens in a row now automatically inserts an em-dash (—); but I wish it were an en-dash (–), as I tend to use this (improperly, I know) instead of an em-dash in iMessage. The em-dash just looks weirdly long in iMessage (even though, again, I know it’s really the “proper” dash to use for my purpose).
 

Dave-Z

macrumors 6502a
Jun 26, 2012
808
1,322
@mpavilion,

Maybe use a text replacement/shortcut? Two hypens = en dash... I've never tried "overriding" it in this manner before but I'd be curious to know if it works.
 

mpavilion

macrumors 6502a
Aug 4, 2014
960
562
SFV, CA, USA
@mpavilion,

Maybe use a text replacement/shortcut? Two hypens = en dash... I've never tried "overriding" it in this manner before but I'd be curious to know if it works.
Interesting... just tried, and unfortunately does not seem to work. But I like the way you think!

(It actually works in reverse — changing manually entered en-dashes into em-dashes, when you set it up that way. But not vice-versa.)
 

saagark

macrumors newbie
Nov 8, 2017
1
0
I've turned off Smart Punctuation and it's still showing me 70 characters with this message. Can anyone please help me to understand why?

Good morning man. Hope you’re well. Please remember to ask for my SACCO statement. I don’t know why they can’t send regularly but anyways. If I can get it this morning please
 

GregA

macrumors 65816
Mar 14, 2003
1,245
14
Sydney Australia
I sent a test text message and it appears to have sent a 97 character text as one message. Counter kept ticking up past the changed 70 character limit.
No you have always been able to go higher than one SMS. It just sends 2, and the receiving phone rejoins it as one.

Try turning off "Smart Punctuation" (introduced in iOS 11) in Settings > General > Keyboard and see if that changes anything.
Thanks that worked for me.
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
48,398
17,012
No you have always been able to go higher than one SMS. It just sends 2, and the receiving phone rejoins it as one.


Thanks that worked for me.
I can't really say that I've seen split SMS messages being joined as one on the recipient side.
 
  • Like
Reactions: NoBoMac

kandasmom

macrumors newbie
Nov 28, 2017
2
0
I've turned off Smart Punctuation and it's still showing me 70 characters with this message. Can anyone please help me to understand why?

I hope that Apple addresses this. I am an Android user & have noticed when my iPhone friends send me an SMS text, messages that are under the '140 character' count are being split because that darn apostrophe symbol is hogging up 60-90 character count spaces. I just spent 12 hours with my phone carrier tech support trying to get them to address this issue. They told me it was my phone... so I googled it & voila!
 

Mascots

macrumors 68000
Sep 5, 2009
1,608
1,303
So annoying.

This happens when using a character that requires additional space in the mapping; emojis and other special characters have always done this. But for some reason, the single quotation mark is causing it, too.

I’ve got a friend on Sprints network with an Android phone and my messages are being obliterated! Chopped into tiny pieces and then sent out of order.
 

kandasmom

macrumors newbie
Nov 28, 2017
2
0
So annoying.

This happens when using a character that requires additional space in the mapping; emojis and other special characters have always done this. But for some reason, the single quotation mark is causing it, too.

I’ve got a friend on Sprints network with an Android phone and my messages are being obliterated! Chopped into tiny pieces and then sent out of order.
I always have long messages appear out of order (receiving & when I send long ones). On my Galaxy S7 in the default app, there is a setting for "auto-combination". When turned on, it will reassemble broken up texts back into one long message for you. Also, on Android, you can trick your carrier into keeping your message in one piece by adding a subject line. This changes the SMS into an MMS message, which allows for a larger size. You have to Google how to add the subject line, because it will be different depending on what texting app you use.
 

GregA

macrumors 65816
Mar 14, 2003
1,245
14
Sydney Australia
So annoying.

This happens when using a character that requires additional space in the mapping; emojis and other special characters have always done this. But for some reason, the single quotation mark is causing it, too.
It's changing the straight apostrophe into a curly one. and quotes too. It looks nicer but wrecks the sms length.
 
  • Like
Reactions: Mascots

Paul_W

macrumors member
Original poster
Jun 8, 2016
72
34
Rutland, UK
Still does this in iOS 11.2. Is this a bug or a feature? I have unlimited sms on my account but surely it must look odd to the recipient getting a load of short messages
 

GregA

macrumors 65816
Mar 14, 2003
1,245
14
Sydney Australia
Still does this in iOS 11.2. Is this a bug or a feature? I have unlimited sms on my account but surely it must look odd to the recipient getting a load of short messages
I just turned smart quotes off in settings - general - keyboard.

Straight quotes are fine.

When you send, many phones just combine the separate messages back into one seamless sms. Not sure which ones don't.
 

kevo0822

macrumors 6502
Jul 13, 2007
330
77
New England
Has anyone with a developer account reported this as a bug? I’d be interested to see if they mark it as “functioning as designed” or not. I don’t have a developer account so I’m not sure I’d get that sort of status information by reporting it through the Feedback app.
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
48,398
17,012
Has anyone with a developer account reported this as a bug? I’d be interested to see if they mark it as “functioning as designed” or not. I don’t have a developer account so I’m not sure I’d get that sort of status information by reporting it through the Feedback app.
You can register as a free developer and submit a bug report at http://bugreport.apple.com
 
  • Like
Reactions: kevo0822

simonmet

macrumors 68020
Sep 9, 2012
2,474
3,300
Sydney
Only very tangentially related — I think it’s cool that typing two hyphens in a row now automatically inserts an em-dash (—); but I wish it were an en-dash (–), as I tend to use this (improperly, I know) instead of an em-dash in iMessage. The em-dash just looks weirdly long in iMessage (even though, again, I know it’s really the “proper” dash to use for my purpose).
You can create a text-replacement that does this and should therefore replace the default behaviour. For example, I used text-replacement to type ¯\_(ツ)_/¯ on my phone with the shortcut “shruggie”.

Annoyingly however, in Safari there doesn’t appear to be a way to reject the text-replacement like you can with auto-correct. This appears to be yet another iOS 11 bug because it works for “omw” (you get a cross to reject the replacement) but not for the one I manually entered. You do however in the Messages app so go figure!

It’s funny how the iOS keyboard doesn’t have a minus symbol because they expect you to use the hyphen. I’m picky about stuff like this too. No shame in being into typography!
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.