App calling unknown class

Discussion in 'iOS Programming' started by smittyCM, May 10, 2011.

  1. smittyCM macrumors newbie

    May 10, 2011
    Hello all,

    I'm having a frustrating situation and I hope someone can guide me in the right direction. I've looked all over for solutions and nothing I find works or relates to my situation. I recently had a app in the app store that I had to pull for legal reasons. Now after a few days, I've figured out the changes I need to make in order to resell the app. I tried (albeit the lazy way) of copying and pasting most of the code into the new app but somewhere along the line I mixed up my connections in IB and when I ran the app I would just get a black screen and tried numerous resolutions to no resolve. I decided to do it the right way and build my new app from scratch (I needed to make adjustments anyway) and after building the app, gdb would pop up saying that there's an "unknown class (the app delegate from the old app) in IB file" and "Terminating app due to uncaught exception 'NSUnknownKeyException', reason: '[<UICustomObject 0x4b46e60> setValue:forUndefinedKey:]". Even after I deleted the old files and created a brand new navigation app without placing any additional code in it, I still get the same error message referring to the same appdelegate that has nothing to do with this app. Please help! No matter what I try, I can't figure out why this is happening. All previous apps that I've created works fine but any new app I create is giving this error becuase of this unknown class that it shouldnt even be aware of since its from a different app. I haven't placed the code because this is occuring even when I create a new app. I hope that anyone who reads this understands what I'm conveying. any help would be greatly appreciated.

Share This Page