App compiles, launches and crashes under 2.1, font problem?

Discussion in 'iOS Programming' started by nottooshabby, Sep 9, 2008.

  1. nottooshabby macrumors 6502

    Joined:
    Jul 12, 2008
    #1
    So there is something my app doesn't like about 2.1. Here is my crash log. It's complaining about a font? Any ideas?


    [Session started at 2008-09-09 22:30:29 -0700.]
    2008-09-09 22:30:31.194 iLeaseMyCar[3528:20b] *** Assertion failure in -[UILabel setFont:], /SourceCache/UIKit/UIKit-738/UILabel.m:438
    2008-09-09 22:30:31.195 iLeaseMyCar[3528:20b] *** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'Invalid parameter not satisfying: font != nil'
    2008-09-09 22:30:31.197 iLeaseMyCar[3528:20b] Stack: (
    2468294987,
    2480804091,
    2468294443,
    2471410724,
    817183141,
    817926218,
    837317240,
    837317032,
    837315376,
    837314643,
    2467789250,
    2467796004,
    2467798264,
    829005112,
    829005309,
    816175835,
    816221412
    )
     
  2. kainjow Moderator emeritus

    kainjow

    Joined:
    Jun 15, 2000
    #2
    Looks like you're assigning the font to nil. Check in your code for your font object being nil.
     
  3. nottooshabby thread starter macrumors 6502

    Joined:
    Jul 12, 2008
    #3
    The only thing that changed was the sdk....I wonder if it's in the xib files...

    UPDATE: I deleted a button on my view in IB and it stopped crashing. So I recreated the button and now it works fine... wierd. Phew, I'm up and running again with the new sdk.
     

Share This Page