App Crash On Launch

Discussion in 'macOS' started by Me1000, Sep 24, 2008.

  1. Me1000 macrumors 68000

    Me1000

    Joined:
    Jul 15, 2006
    #1
    Coda has started to crash on startup for me.

    I have downloaded the latest version from Panic's website, and I downloaded and installed the latest combo update (10.5.5) from Apple...

    On the crash report I see

    When i saw "@executable_path/../Frameworks/FTPKit.framework/Versions/A/FTPKit" I thought maybe the combo updater would fix that.

    It still crashes all the time!

    I really need to get this fixed.

    Any idea how to do this? Could I just grab that file off any other Mac I have around the house (assuming it exists)?


    Thanks,
     
  2. Me1000 thread starter macrumors 68000

    Me1000

    Joined:
    Jul 15, 2006
    #2
    Ok, I was able to figure this out on my own...

    I had to completely delete coda.app (move it to the trash, and empty it) then download it again from their site to replace it.

    Maybe this thread will help someone in the future.
     
  3. Aquatoad macrumors newbie

    Joined:
    Apr 16, 2009
    #3
    I had this same problem almost 2 years later. Posting my solution for any subsequent googlers.

    I tried to follow the info above, but didn't have my serial due to hotmail inactivity erasing my old email (contacted Panic for the info). But while I was waiting:

    1. Downloaded coda per above
    2. Opened the coda.app package for both my broken app and freshly downloaded app (requires apple developers toolkit)
    3. Replaced Framework folder in the broken app with folder from download.
    4. Replaced Resources folder in the broken app with folder from download.

    Relaunched and it worked fine. Hope that helps.
     
  4. tlettington, Apr 13, 2012
    Last edited: Apr 13, 2012

    tlettington macrumors newbie

    Joined:
    Apr 13, 2012
    #4
    Coda stops running randomly

    Coda quits at random times. I can relaunch from the dock and run awhile and then it quits again (Lyon). ANNOYING ! Panic can't figure out why. Coda generates no crash file - just stops running and disappears from the desktop and has to be restarted. I deleted the .app file and reinstalled a fresh copy from Panic. No change in behavior.

    Anyone have any ideas?
     

Share This Page