App icons keeping coming back to dock after i remove them

Discussion in 'macOS' started by dgreen97, Sep 12, 2015.

  1. dgreen97 macrumors newbie

    Dec 21, 2011
    any idea on why app icons would consistently keep going back into the dock after i right click and remove them, or drag them off of the dock to go poof. Ill open a program, close it, then it leaves the app icon in the dock. I remove the app icon from the dock, the next time i open the program it does the same thing. Any idea on how to fix this? I only want open applications in the dock.
  2. MJWMac1988 macrumors member


    Aug 25, 2015
    Western Nebraska
    I'm just guessing, but maybe the dock's preferences are corrupt. Maybe you already know this, but go to:

    username (aka home folder) > Library > Preferences

    Find the file called "" or "" It may have some other file-extension suffix in Yosemite (which I haven't used), but the first part of the name should definitely be "" Delete that file and immediately log out and back in again.

    WARNING: Keep in mind that this will reset your dock to the original factory default set of icons. If you have lots of non-default icons in your dock, take a screenshot of it before you delete the preferences. That way you can use it as a guide when re-adding icons to your dock.
  3. dgreen97 thread starter macrumors newbie

    Dec 21, 2011
    hi i tried this out but they still keep coming back. just for clarification i mean i actually remove the icon from the dock and make it poof, or right click on the icon and remove from dock. i have no idea why they keep reappearing after i remove them from the dock and then reopen the application later and then it sticks in the dock again.

    i like to have my dock like a taskbar where it only shows running programs and everything else not showing.

  4. khnyc1 macrumors newbie


    Oct 15, 2011
    New York, NY
    I'm having a similar problem. I deleted Chrome and no matter what I do from the various suggestions on the Forum discussions and other sites, it reappears the next time I turn on my computer. I don't know what else to do.

Share This Page