App icons missing after 10.6.6 update

Discussion in 'macOS' started by jeffy.dee-lux, Jan 6, 2011.

  1. jeffy.dee-lux macrumors 6502a

    Joined:
    Nov 19, 2003
    Location:
    montreal
    #1
    I've done a quick search and it doesn't seem that anybody else is having this issue from what I can see. After running today's update, trying out the App Store for the first time, I noticed that the icons for many of my apps have disappeared from the dock. They also don't show up in the Command-Tab floater window. I've tried logging out and rebooting but the problem persists. The problem is only with certain apps:
    Safari, iChat, Text Edit, Firefox, Address Book, Calculator, iPhoto...
    While other apps seem to be fine:
    Mail, Finder,iCal, iTunes, MS Office, System Preferences.... I can't seem to figure out a trend, I thought at first maybe it's only apps that are available in the App Store, but I don't think things like TextEdit and Dictionary are in there. Any ideas??

    Oh ya, the icons do show up in the Apps folder and in the Get Info window for the apps in question.
     

    Attached Files:

  2. jeffy.dee-lux thread starter macrumors 6502a

    Joined:
    Nov 19, 2003
    Location:
    montreal
    #2
    i can still open these apps from the Doc by clicking on the empty space, the name of the app still shows up when i hover the cursor over the spot where the icon would normally be. Randomly, the Calculator logo just came back when I tried opening it. This is messed up!!!!
     
  3. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #3
    Try this real quick. Open Terminal, and type (feel free to copy/paste, but otherwise make sure to get all the spacing exactly correct):
    Code:
    killall -HUP Dock
    That will restart the Dock, without affecting anything else running. Sometimes that's dealt with issues like this for me.

    Also, just as a test, you can try removing one of the apps that doesn't show an icon from the Dock, then dragging it back onto the Dock. The icons may just need to be refreshed for some reason.

    jW
     
  4. jeffy.dee-lux thread starter macrumors 6502a

    Joined:
    Nov 19, 2003
    Location:
    montreal
    #4
    Thanks for your help! Killing the dock didn't help, but removing the apps from the dock one at a time and putting them back seems to do the trick. Thanks! I'm really curious if anybody else had this issue come up today...
     
  5. dpbrown02 macrumors newbie

    Joined:
    Jan 6, 2011
    #5
    Finder icon missing

    I had the same problem after I updated, except with the finder icon. This is a little more tricky as you can't remove it from the dock and re-apply it. I tried killing the dock but that also did no good. does anyone else have this issue???
     

    Attached Files:

  6. macmulisha macrumors member

    Joined:
    Sep 21, 2008
    Location:
    florida
    #6
    Where Time Machine was is now a question mark. I restarted and nothing. Help? I'm not to comfortable in Terminal.
     
  7. lotones macrumors regular

    Joined:
    Aug 6, 2010
    #7
    Did you try repairing permissions? I know it's almost cliche' at this point, but it seems to fix a lot of the occasional weirdness on my mac. Especially after major software installations.

    Applications>Utilities>Disc Utilities>select disc>repair permissions
     
  8. jeffy.dee-lux thread starter macrumors 6502a

    Joined:
    Nov 19, 2003
    Location:
    montreal
    #8
    lol, ya i know what you mean about the cliché. I did indeed try repairing permissions and it didn't help. Thanks though. I don't know what to do about the missing Finder icon! That's a toughy, I guess that'll need a more thorough solution.... Really surprised this is only happening to two people so far! It seems obviously related to 10.6.6 or the App Store, and yet, it's only affecting a few people. I can't imagine it's hardware specific, but just in case, I'm on a 2007 MBP.
     
  9. ryanrich macrumors regular

    Joined:
    Nov 16, 2010
    Location:
    Cape Town, South Africa
    #9
    I'm having the same issue with my Finder icon gone after updating to 10.6.6 this morning and have been trying to fix it all day!

    If I drag Finder.app to the Dock it creates another shortcut fine and the icon displays, but the main Finder shortcut is showing nothing except the glowing light. So frustrating! :(

    Have tried using Candybar to set an icon and also cleared all the cache with OnyX, have repaired permissions, no dice...
     
  10. appleboyy macrumors 6502

    Joined:
    Jun 18, 2010
    #10
    Try running the 10.6.6 combo updater, http://support.apple.com/kb/DL1349

    Might work?
     
  11. Macinsc macrumors newbie

    Joined:
    Jan 9, 2011
    #11
    App icon missing

    I updated to 10.6.6 and lost Picasa. Spotlight found only a few pics. The Dock icon was a question mark. I downloaded the free uitliy EasyFind and had it check all folders. Nothing new. Then I checked also search invisible files and folders. It found the disk image for Picasa. Clicking on the DiskImage it stated Picasa is running from the DiskImage, would you like to copy to Applications folder? Problem solved.

    Thanks to all who provided suggestions
     
  12. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #12
    Same thing happened to me but it was just one application. A simple remove from dock and then putting it back on fixed it. So far that problem hasn't come back.
     
  13. IndyJ macrumors newbie

    Joined:
    Jan 18, 2011
    #13
    Apps disappeared fixed

    The same thing happened to me after a Time Machine restore. I am running 10.5.8, but I thought the fix may work for 10.6 as well: I booted from my Bootable utilities on an external HD, ran Disk Warrior, and then Disk Utilities --> repair permissions and that seemed to fix it. This was after running Disk Utilities from the internal HD and that didn't fix it. Hope that helps. Anyone know why this happens?
     
  14. mscriv macrumors 601

    mscriv

    Joined:
    Aug 14, 2008
    Location:
    Dallas, Texas
    #14
    I've been having this same problem with my dock. Open applications would not show the white/blue open app dot below them. For reference I'm still on Snow Leopard. I tried repairing permissions, but that didn't do anything. I tried the terminal command for resetting the dock and that did the trick. Some of the research I've done says the problem could come back, but for now everything seems to be working as it should.

    Thanks for the help to those who posted solutions.
     

Share This Page