App in my dock all of a sudden has a question mark

Discussion in 'iMac' started by bobright, Apr 21, 2013.

  1. bobright macrumors 601

    Joined:
    Jun 29, 2010
    #1
    This app which is 1password also doesn't work anymore. Anybody know what has happened?

    I'm not sure if I should install the app again, do not want to overwrite and muck up any of my already saved data. If I go that route of re-installing wil I lose all my saved logins/data?
     
  2. Lancer macrumors 68020

    Lancer

    Joined:
    Jul 22, 2002
    Location:
    Australia
    #2
    First are you new to Mac?

    Did you copy (or install) the app to the Application Folder? If not it might have been installed or kept on the DMG.

    Can you find the app in the Application folder?
     
  3. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #3
    Drag the icon off your Dock to get rid of it. Have you tried launching 1Password from the Applications folder? If it works, just re-drag the app to your Dock. If it doesn't work, you should be able to uninstall/reinstall without losing your user data. As always, it's a good idea to have a current backup before doing such things.
     
  4. bobright, Apr 21, 2013
    Last edited: Apr 21, 2013

    bobright thread starter macrumors 601

    Joined:
    Jun 29, 2010
    #4
    I am new to Mac but know the basics. I did drag and drop to my apps folder it wasnt mounted or simply opened from the dmg sitting in my downloads folder. I cant find it in my Applications folder but did not delete it not sure what happened here.

    ----------

    It isn't there which is strange like I said I have not deleted it. Yet when using 1Password via the Chrome extension its working. :confused:

    I have backed up data to Dropbox and also have the app on my iPhone/iPad with my data on there, they should work together as in if I do a reinstall on my Mac I'll be able to retrieve this data right?

    Edit: nevermind just reinstalled and the app is working still registered and all nice
     
  5. Lancer macrumors 68020

    Lancer

    Joined:
    Jul 22, 2002
    Location:
    Australia
    #5
    Good to hear, we've all been there when first using OS X when they went to DMG and not installing them in the right place only to find applications disappearing when the DMG was ejected.
     
  6. bobright thread starter macrumors 601

    Joined:
    Jun 29, 2010
    #6
    I could have sworn that wasnt the case but maybe it was:eek::eek:
     

Share This Page