App installation get stuck at "Installing"

Discussion in 'iOS Programming' started by MacMan988, May 26, 2014.

  1. MacMan988 macrumors 6502a

    Joined:
    Jul 7, 2012
    #1
    Hi, I have been assisting a client to get my app installed on his iPhone 5S. iTunes finished syncing and all operations. But still both the iPhone and the iTunes shows "Installing" next to the app and doesn't seems to be ever going to finish installing it.

    Any ideas?
     
  2. DannyBres macrumors 65816

    DannyBres

    Joined:
    Oct 30, 2007
    Location:
    UK
    #2
    How is he installing it?

    How have you sent him it?

    Is his device registered on your dev account?
     
  3. MacMan988 thread starter macrumors 6502a

    Joined:
    Jul 7, 2012
    #3
    Hi. Exported the app using the "Save for ad-hoc or enterprise distribution" option and sent him the .ipa file.

    The device is registered and the app is signed with updated provisioning profile.

    He is installing via iTunes. His iPhone is plugged into his PC and he tried to sync the iPhone with iTunes.
     
  4. chrono1081 macrumors 604

    chrono1081

    Joined:
    Jan 26, 2008
    Location:
    Isla Nublar
    #5
    A way to get better error messages is to use this tool:
    http://support.apple.com/downloads/#iphone configuration utility to load apps on to your phone.

    I use this at work to test my build on non-provisioned devices. It may give you a better error message.
     
  5. MacMan988 thread starter macrumors 6502a

    Joined:
    Jul 7, 2012
    #6
    Hi, thanks for the information.

    I have been sending ipa files to clients for a long time and never had a problem like this. The app is now loaded partially to the device it seems. The icon is missing and it shows the default icon. Tapping on the app makes the OS trying to download the app from the App Store it seems.
     

Share This Page