app is skipping songs - nothing plays

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by patent10021, Oct 12, 2017.

  1. patent10021, Oct 12, 2017
    Last edited: Oct 12, 2017

    patent10021 macrumors 68030

    patent10021

    Joined:
    Apr 23, 2004
    #1
    Recently Apple Music is skipping songs for any albums, playlists....everything. The app just keeps moving down the list till the end.

    No app switch or restarts fix it. I usually just wait for 20 minutes or so and it returns to normal. But this seems to happen daily.


    I'm not sure if it's exactly the same bug but this same thing or similar thing happened in Feb 2017.
    http://www.idownloadblog.com/2017/02/02/apple-music-randomly-skipping-songs-you-are-not-alone/

    Older iTunes 12.3.1 on old MacBook is working fine.
     
  2. Richdmoore macrumors 68000

    Richdmoore

    Joined:
    Jul 24, 2007
    Location:
    Troutdale, OR
    #2
    I have been having similar problems with listening to songs using iTunes Match, on iOS & tvOS, but iTunes on High Sierra is working fine. If I download the songs first to my iOS device they also work, just the streaming is skipping songs when I attempt to play them.

    Also, mine are always the same songs, so it is very repeatable, and has been going on for two weeks. I am working with AppleCare to try and fix it, but no solution has been discovered yet.
     
  3. mic j macrumors 68030

    Joined:
    Mar 15, 2012
    #3
    I have had this problem in the past. Look to see if the songs in your iTunes library have '!" next to them. All of the ones in our library were that way. Since I was at the point of modifying the library anyway with some updates, I deleted all the songs from the library and iCloud library, then re-added to the iTunes library. Of course, I then had to go through the process of re-scanning my iTunes library to get the music back into the iCloud library. However, after doing this, Apple Music has been playing as expected.
     
  4. Richdmoore macrumors 68000

    Richdmoore

    Joined:
    Jul 24, 2007
    Location:
    Troutdale, OR
    #4
    Nope they didn’t have anything next to them. Today while trying to troubleshoot with a senior advisor (the engineering team asked for more info) everything g started working again, even the songs that didn’t work two days ago. No idea what happened, but glad the issue was fixed.
     
  5. patent10021 thread starter macrumors 68030

    patent10021

    Joined:
    Apr 23, 2004

Share This Page

4 October 12, 2017