App or Installer Killed my iPhone?

Discussion in 'iOS Apps' started by Donz0r, Jul 17, 2008.

  1. Donz0r macrumors 6502a

    Joined:
    Jun 29, 2006
    #1
    So I downloaded and installed the "Mind Warp" optical illusion app, and while it said ''Installing" I went to open up some other app, "photos" i think, and it froze, I held down the switch to turn the iPhone off. Then it was stuck at the reload screen w/ the apple, FOREVER!!

    There's no way an App from the App Store could do this to my iPhone, right?

    I figured out how to restore my iPhone even though it was unusable. (hold down both buttons for 30 seconds, then hold down home key and plug into computer and keep holding down home key for another 20ish seconds until this icon pops up on the iPhone)

    Of course my backup was 'invalid' or 'corrupted' so i had to restore my iPhone as a new iPhone. What a pain in the ass!!!!

    Doesn't apple screen for viruses like this?
     
  2. iNfowarrior macrumors member

    Joined:
    Jul 15, 2008
    #2
    Its not a virus. It appears to be a memory issue with the iPhone. My experience thus far is that it does not like doing anything else while installing an app. If you do, it WILL crash. period.

    Its something that needs to be addressed immediately. Restoring my new iPhone 3G only a few hours after activation due to buggy apps/software was not well received.
     
  3. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #3
    Try 14 restores in the past week!! ;)

    No joke - fourteen restores due to apps either not installing correctly, backups not working, or cancelling syncs. Not fun at all, considering it takes more than hour to restore and re-sync, not to mention the PITA of having to go through and change all of the settings again, since I can't use backups (which take hours to make in the first place) ... :mad:
     
  4. aerospace macrumors 6502a

    Joined:
    Jun 26, 2007
    #4
    The iPhone is the worlds best Uni-tasker. It does lots of things well, but only one at a time. It is itentionally designed to not run tasks in the background and therefore forego doing 2 things at once, music being the exception.
     
  5. Telp macrumors 68040

    Telp

    Joined:
    Feb 6, 2007
    #5
    You mean the iPod app. I guess I have gotten lucky. Lots of crashes, no restores though. And none during the installation of a new app.
     
  6. skubish macrumors 68030

    skubish

    Joined:
    Feb 2, 2005
    Location:
    Ann Arbor, Michigan
    #6
    Trying to run another app while installing an app is a recipe for disaster on any computer.

    I have had plenty of crashes but no restore on my iPhone.
     
  7. MattZani macrumors 68030

    MattZani

    Joined:
    Apr 20, 2008
    Location:
    UK
    #7
    Sometimes an app wont fully open, and keep quitting, power off and back on fixes though.
     
  8. The Phazer macrumors 68030

    Joined:
    Oct 31, 2007
    Location:
    London, UK
    #8
    Not had any problems with that app myself.

    Phazer
     
  9. nando2323 macrumors 6502a

    Joined:
    Aug 15, 2007
    #9
    I have installed almost every app on my phone while doing other things with no problems at all. I think maybe you guys might have a hardware issue that may need to be looked at. Especially the one guy that had to do 14 restores in a week that's just unheard of, I would take it back and get a new one.
     
  10. xsmasher macrumors regular

    xsmasher

    Joined:
    Jul 18, 2008
    #10
    "Mind Warp" is not to blame - could be any app

    This is a problem with the installer, not with "Mind Warp" - if anyone else has this problem, try the fixes in this thread:

    iPhone Stuck On Reboot Apple Logo Screen
    http://forums.macrumors.com/showthread.php?t=334220

    Full disclosure: I wrote "Mind Warp," and it's not a virus. :)
     
  11. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #11
    Wirelessly posted (iPhone 3G (white): Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_0 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5A347 Safari/525.20)

    Yeah, I had a similar experience with a different app. I was convinced the app was faulty! Turns out the app was fine - it's just a problem with 2.0's Installer. ;)
     
  12. ximon macrumors newbie

    ximon

    Joined:
    Jun 18, 2008
    #12
    This just happened to me - I tried to open settings while installing 2dsense and the iPhone crashed, now it will only boot as far as the Apple logo. I tried waiting a while but all that happened was the phone started to get hot.

    I will restore it when I get home this evening. What a PITA!
     
  13. jaseone macrumors 65816

    jaseone

    Joined:
    Nov 7, 2004
    Location:
    Houston, USA
    #13
    I've had this happen a few times now and have never had to restore my iPhone, I usually leave it on the Apple logo screen for a long while to give it a chance to do it's thing (install the App that it crashed on trying to install) and if it doesn't boot before I lose my patience then I do another reset and that tends to boot the phone without trying to install the app again.

    All in all the app installation process on the iPhone is buggy as heck, it shouldn't take over half an hour to install a simple program!!!
     
  14. sUGArDawg macrumors regular

    sUGArDawg

    Joined:
    Jul 23, 2008
    #14
    I just wait the 10 seconds it takes to install an app.
     
  15. cocky jeremy macrumors 68040

    cocky jeremy

    Joined:
    Jul 12, 2008
    Location:
    Columbus, OH
    #15
    I always do stuff while i install apps.. from the App Store and Cydia. Never have had any problems.
     
  16. mekopolis macrumors regular

    Joined:
    Feb 10, 2008
    #16
    if you want to experience what the original thread starter is talking about
    go to the wifi app store on the iphone/touch, install or upgrade an app, and whilst it is doing that, try running another app...it will eventually freeze and corrupt the firmware

    then you have to restore
    "1. Turn the iPhone ON
    2. CONNECT it to the dock
    3. Make sure iTunes is open so you'll know when it enters DFU mode
    4. HOLD the Power/Sleep-Wake button AND the Home button for 10 seconds
    5. RELEASE only the Power/Sleep-Wake button and continue to hold the Home button
    6. WAIT until iTunes recognizes the phone in DFU Restore mode (in Windows a bubble pops up saying it recognized new hardware "DFU Mode" or something to that effect)
    The last step may take SOME TIME, like, say, even 60 seconds or so. The screen should be OFF (black), if you see the "Connect to iTunes" logo, START OVER. It may take a few tries to do the steps just right, just reboot (hold both Power/Sleep-Wake AND Home until the Apple logo appears and the phone turns back on) then try again.
    "

    and your backup is useless
    so you have to resync everything and it is a pain

    but try at your own risk

    edit: it has happened to me 3 times in the last week
     
  17. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #17
    Well, I ended up with a final count of 27 restores on my first iPhone before I took it in and got a new one ... Unfortunately the new phone has required four restores in just a few days, so it seems that the problem is not actually with the phone but with the app installation mechanism in the 2.0 software.

    I'm really looking forward to 2.1 - it will be nice to finally have a dependable iPhone instead of one that needs to be restored every day.
     
  18. cocky jeremy macrumors 68040

    cocky jeremy

    Joined:
    Jul 12, 2008
    Location:
    Columbus, OH
    #18
    I have done that. I opened AIM while installing an app and it was fine. Sucks though for those that got screwed by that. I might wanna not try that anymore. lol.
     
  19. Heraklitus macrumors member

    Joined:
    May 30, 2008
    Location:
    El Cerrito, CA
    #19
    Im having the same sorts of problems--I don't even do updates anymore. They just end up borking my iPod Touch. I'm waiting for a firmware / iTunes update that claims to have fixed this.

    I think the suggestion that this is hardware issue is mistaken.
     
  20. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #20
    I agree. This has happened to me 37 times since July 11th (total, on two different iPhones) and three times on my previously PERFECT iPod Touch. Here are the troubleshooting steps I've taken, with no effect:

    • Reinstall iTunes (7.7)
    • Upgrade iTunes (7.7.1)
    • Unplug USB hub, connect iPhone directly to rear USB port on iMac
    • Delete all backups, set up as new phone (x25)
    • Restore using different PC (x2)
    • Get new iPhone
    • Delete 5A347 firmware, re-download fresh copy
    • Delete all apps from HDD, redownload through iTunes
    • Disable app sync in iTunes, install one by one directly on iPhone (x3)
    • Install apps one by one through iTunes only (no direct installs on iPhone)
    • Leave iPhone off overnight, attempt reboot in morning (x2)

    I don't think it's hardware related, because prior to 2.0, my iPod Touch NEVER crashed. Also, I had my iPhone 3G replaced a week ago in an attempt to fix this problem, but the new one freezes just as often as the first.

    Good job, Apple.
     
  21. Hustle macrumors 6502a

    Joined:
    Jul 29, 2007
    Location:
    USA
    #21
    This has happened a few times with me. Luckily, I haven't had to restore, I just tried turning the phone off when it's sitting on the Apple logo and the home screen appeared. When installing Apps, don't do any other tasks.
     
  22. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #22
    Wirelessly posted (iPhone 3G (white): Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_0 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5A347 Safari/525.20)

    Yeah, guess I didn't mention that. When I'm installing/syncing apps, I give the iPhone a wide berth - I try not to even breathe on it. Doesn't seem to help, though. ;)
     
  23. oomega1 macrumors member

    Joined:
    May 29, 2003
    #23
    this has happened to me too. But my phone wouldn't go to the restore. It would only turn off and back on. It was on the apple logo for like 4 min each time. I finally gave up trying to get to restore mode and after about 10 minutes it worked. What a scare though. Seriously though this makes me want to buy applecare now. Apple should get their act together. If more people get this, please report it so Apple can be aware of such a bad release and fix this.

    P.S. Btw I think Apple just wants us to buy applecare.
     

Share This Page