iPhone App Store apps not updating (4S, 6.1.2 JB)

Discussion in 'Jailbreaks and iOS Hacks' started by occamsrazor, Nov 18, 2013.

  1. occamsrazor macrumors 6502

    occamsrazor

    Joined:
    Feb 25, 2007
    #1
    Hi,

    Been using my iPhone 4S with jailbroken 6.1.2 for a long time, no problems. Then last week I realised that my App Store apps (free ones) weren't updating, and now have a list of 18 apps in the App Store that haven't updated.
    When I hit the "update" button next to the app in App Store > Updates nothing happens at all, it doesn't change to anything else.
    When I update all the apps in iTunes it downloads the new versions, and when I sync it appears to be copying them over - but none of the apps on the iPhone actually get updated.

    Any ideas?

    Thanks
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    Do the apps require iOS7 ? If so, they will not update.
     
  3. occamsrazor thread starter macrumors 6502

    occamsrazor

    Joined:
    Feb 25, 2007
    #3
  4. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #4
    Have you tried a normal restart to see if it fixes the problem?

    If that doesnt work, try and boot up while holding the volume up key. This'll disable all your tweaks. See if you can install updates now
     
  5. occamsrazor thread starter macrumors 6502

    occamsrazor

    Joined:
    Feb 25, 2007
    #5
    Good ideas, just tried the volume-up and normal restart - but still no updates...
     
  6. derrick2005 macrumors regular

    Joined:
    Oct 8, 2011
    #6
    I had this problem, the only solution to fix it was ilex rat
     
  7. braddick macrumors 68040

    braddick

    Joined:
    Jun 28, 2009
    Location:
    Encinitas, CA
    #7
    Try deleting one of them off your iPhone, rebooting and then adding it again to your iPhone (after updating it within iTunes).

    A pop up should advise you it needs a newer version of iOS yet you can download an earlier version.
    Agree to that pop up and it should then work.

    If so you will then need to manually do so with the other apps too.
    A pain, to be sure, but also a time of reflection on if you truly need the apps you're having to re-download or not.
     
  8. occamsrazor thread starter macrumors 6502

    occamsrazor

    Joined:
    Feb 25, 2007
    #8
    Thanks for your suggestion, just tried that. I deleted Speedtest on iPhone, then tried to re-install using both via iTunes and iPhone directly. In iTunes it's sitting there saying "installed" and in iPhone App Store it just has the "cloud" icon - but isn't on the phone.
    Separately, I've just tried to download a new (never installed before) app via iPhone Appstore. When I did, it now shows with the cloud icon, but is not on the phone.

    Never had this before, it's very annoying...

    ----------

    Thanks, but if booting up with the volume-up key didn't fix it, isn't this essentially the same?
    I'm starting to think this is more an issue with the Apple software than the Cydia side of things.
    It sounds like a pain but maybe the only thing left to try.
     
  9. braddick macrumors 68040

    braddick

    Joined:
    Jun 28, 2009
    Location:
    Encinitas, CA
    #9
    Sorry that didn't work for you.
    I'd still speculate it is a Cydia side of things and not a stock issue as I've only heard of it happening on jailbroken iDevices.

    OK- go with the iLEX RAT suggestion. Download the source and the tweak and go from there.

    You will have your answer within ten minutes of beginning to do so.
    Fingers crossed that will be the cure to this problem you're having.
     
  10. occamsrazor thread starter macrumors 6502

    occamsrazor

    Joined:
    Feb 25, 2007
    #10
    Thanks, I guess I'll have to do that when I can find time. One question - what will I have to restore after doing that to get my phone back to how it is? Appstore apps, Cydia apps, settings, etc? Thanks.
     
  11. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #11
    Essentially have to restore everything
     
  12. derrick2005 macrumors regular

    Joined:
    Oct 8, 2011
    #12
    My experience with ilex rat was that it restored the phone to stock but I had backed up the phone to iTunes beforehand. Once I used ilexrat I restored from the backup 10 minutes prior (it didn't requite me to update to ios 7) and then I had my settings, messages etc back. The things is I had to start over and install everything again from Cydia. Before you start the process if you download Appinfo from Cydia you can get a printout of all the cydia apps and tweaks you have on your device so you have a list of what you need to manually reinstall.

    I had the App store issue for weeks and it drove me so crazy that I bought the 5s just out of frustration. That was a 4 day experiment. So happy I used ilexrat and 30 mins of reinstalling the cydia tweaks and now my 5 is working perfectly.
     
  13. occamsrazor thread starter macrumors 6502

    occamsrazor

    Joined:
    Feb 25, 2007
    #13
    Hmmm, looks like I have some work cut out for me, I won't be able to get around to this right now. Or perhaps I can drag it out until the IOS7 jailbreak becomes available. Thanks a lot for all your replies, appreciated.
     
  14. mickey72 macrumors newbie

    Joined:
    Nov 16, 2013
    #14
    i had a similar issue, i ended up rebooting the router. and if that doesn't work, try ilex rat, remove all of your tweaks and start over. hope this helps
     

Share This Page