iPhone App Store apps won't completely update on jailbroken iPhone 5

Discussion in 'Jailbreaks and iOS Hacks' started by 3rdiguy, Mar 8, 2013.

  1. 3rdiguy, Mar 8, 2013
    Last edited: Mar 8, 2013

    3rdiguy macrumors 6502a

    3rdiguy

    Joined:
    Sep 17, 2012
    #1
    Hi, I'm a noob to jailbreaking and wanted to know how can I completely update Apple App Store apps on my iPhone 5. Every time I try to update the progress bar get almost to the end of installing and stops and it says it can't download right now. Some of my most important "regular apps get stuck at this process and it would be difficult to replace info in some of the apps like my PDFs in iBooks. Can I update without plugging into a computer because that isn't a option.
     
  2. sagar4995 macrumors 6502a

    sagar4995

    Joined:
    Aug 11, 2012
    Location:
    Dubai, UAE
    #2
    same problem. i retry a couple of times and it worked for me.
     
  3. 3rdiguy thread starter macrumors 6502a

    3rdiguy

    Joined:
    Sep 17, 2012
    #3
    Still doesn't work and I have like 15 apps that need to be updated. Keeps giving me the "can't download at this time" message
     
  4. fisherking macrumors 601

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #4
    this happens to me too. what i've done a few times: uninstall the app, then re-install it. THAT works every time.. (but it IS a nuisance)...
     
  5. Jlrera macrumors member

    Joined:
    Apr 14, 2011
    Location:
    East Amherst
    #5
    I just started running into this issue? Pretty weird, if I do a hard reset then it seems to work, but annoying none the less. I only have intelliscreen, auxo and f.lux installed, I don't think any of those could cause it?
     
  6. headcase macrumors 6502

    headcase

    Joined:
    Jul 4, 2007
    Location:
    Raleigh, NC
    #6
    The occasional inability to download apps from the App Store is a known issue, and happens on stock non-jailbroken iOS devices too. Has nothing to do with your phone jailbroken. You can also try quitting the App Store and relaunching it to remedy when this occurs.
     
  7. UseYourIllusion macrumors newbie

    Joined:
    Mar 21, 2012
    #7
    Uninstalling the app and trying to reinstall doesn't work for me. Some apps successfully update but I don't even see the progress bar or anything like that anymore. Haven't for a while actually and can't restore now because of 6.1.3... I uninstalled evernote and tried to reinstall but I hit the install button and nothing happens. No message, nothing. I'm on 6.1
     
  8. redbeard331 macrumors 6502a

    redbeard331

    Joined:
    Jul 21, 2009
    #8
    I've had that problem with Soundhound since yesterday, can't even delete it..
     
  9. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #9
    I haven't had any issues updating apps on my jailbroken iPhone or iPad. My wifes iPhone that is not jailbroken has had issues lately though. I think it's more of an iOS 6.1.x issue than a jailbreaking issue.
     
  10. ~Ks383~ macrumors 6502

    Joined:
    Jul 6, 2011
    #10
    I'm inclined to agree with this. I've had exactly the same experience recently.
     
  11. DigitL macrumors member

    Joined:
    Mar 8, 2013
    #11
    Gotta have something to do with the jailbreak. Didn't experience the issue before the jailbreak.

    I've been updating my apps through iTunes and then syncing my phone with no issues.
     
  12. ckong macrumors regular

    Joined:
    Nov 12, 2009
    #12
    I update through iTunes and had this problem twice. Each time I just downloaded a free app, then updated. I know it sounds unusual but I partly did it as a test of my iTunes account and to possibly reset any queuing mechanism the Apps Store might have. Updates worked after that so go figure.
     
  13. Frenchjay macrumors 68000

    Frenchjay

    Joined:
    Jul 6, 2010
    #13
    Having the same problem in the last few days. I can delete and reinstall fine but the update stops nearing completion and days retry or done.
     
  14. LSUtigers03 macrumors 68020

    LSUtigers03

    Joined:
    Apr 9, 2008
    #14
    This is what my brother has to do on his iPhone 5. Mine updates apps fine though.
     
  15. Diz13oymike macrumors newbie

    Joined:
    Mar 28, 2013
    Location:
    Guyana
    #15
    I can't delete, install any apps from AppStore... Not even third party's ipa... Why tho??? When I update it stop at prox 98% n says cant update or install at this moment. Iphone 4s iOS 6.1.2 jailbroken it's their a daemon running killing this or is their a dead one???
     
  16. Diz13oymike macrumors newbie

    Joined:
    Mar 28, 2013
    Location:
    Guyana
    #16
    I'm having the same problem but I can't uninstall!! Nothing will only from cydia... If I delete and respring or reboot the app is their looking at me!
     

Share This Page