App Store broken.

Discussion in 'OS X Mavericks (10.9)' started by sgarrand, Oct 6, 2013.

  1. sgarrand macrumors newbie

    Joined:
    Feb 3, 2008
    #1
    I attached an image of the error. When I attempt to install an app it says:

    "We could not complete your purchase."
    Failed to verify the preflight file. It is not signed by Apple.

    I've seen a few fixes that involved deleting various com.apple.appstore preferences in /Caches and in /Library but have had zero success. Any ideas? Thank you very much.

    Scott
     

    Attached Files:

  2. w0lf macrumors 65816

    w0lf

    Joined:
    Feb 16, 2013
    Location:
    USA
  3. sgarrand thread starter macrumors newbie

    Joined:
    Feb 3, 2008
    #3
    Good idea and I did install the App Store from an OSX install DMG with no luck. There's currently no way to uninstall the App Store that I'm aware of.

    Scott
     
  4. scottishwildcat macrumors regular

    Joined:
    Oct 24, 2007
    #4
    Anyone get anywhere with this? I'm having the same problem :/
     
  5. scottishwildcat, Oct 24, 2013
    Last edited: Oct 24, 2013

    scottishwildcat macrumors regular

    Joined:
    Oct 24, 2007
    #5
    Somebody on the Apple discussion board just found a workaround for this (I won't say it's a solution as it does lower your security settings a little):

    Somebody else there claims that turning off guest user access also solved the problem for them, which would be a better option if it works I guess but I haven't tried it.

    EDIT: Setting both keychain options to "Best Effort" rather than "Off" also seems to work for me, which is slightly better I guess.
     

Share This Page