App Store error 1004

Discussion in 'Mac Apps and Mac App Store' started by hyhybt, Aug 26, 2014.

  1. hyhybt macrumors member

    Joined:
    Sep 23, 2013
    #1
    Somebody please help. For several days now I've been trying to download Yosemite PB2. Every time, I get Error 1004. Some things that didn't work: deleting preferences and cookies, switching users, booting from a different disk. Anything else under Purchases, I can download fine. I tried asking on the Apple forum and they deleted my question LYING that it contained information about the beta. This is obviously absurd, since the problem is with the store and anyone who read the post could plainly see I couldn't even get the beta in order to find anything out about it to reveal!
     
  2. hyhybt thread starter macrumors member

    Joined:
    Sep 23, 2013
    #2
    OK.... so, nobody answered, but after a couple more days of trying it spontaneously changed from not working to working for no apparent reason whatsoever. So all's well, I guess.
     
  3. Stativarius macrumors newbie

    Joined:
    Jul 14, 2014
    #3
    In case anyone else runs into this same issue...

    The error is caused when you have the Yosemite Beta 1 Installation app in your applications folder and are trying to download the Beta 2 Installation app. Both install versions are named 'Install OS X Yosemite Beta' so the OS sees them as the same file, but the App Store treats them as separate apps. The App Store doesn't have permissions to overwrite the existing file when downloading a new one of the same name, so you get error 1004.

    To fix this, simply delete the old 'Install OS X Yosemite Beta' app in Launchpad or directly from the Applications folder. Finally, quit and relaunch the App Store and then re-download Yosemite Beta 2. It should work perfectly.
     
  4. hyhybt thread starter macrumors member

    Joined:
    Sep 23, 2013
    #4
    Thanks.

    Strange thing is, while I did at some point get rid of the old installer, it wasn't between the last time downloading didn't work and the time it did.
     
  5. cebseb macrumors regular

    Joined:
    Feb 21, 2011
    #5
    Oh thank you. Thank you. Thank you!! You just saved me and my colleague a few hours of headache.
     
  6. Siannath macrumors member

    Siannath

    Joined:
    Nov 21, 2012
    Location:
    Lima, Perú
    #6
    Problem solved! Thank you! :D
     
  7. morrismh macrumors newbie

    Joined:
    Jun 1, 2010
    #7
    Thanks

    Deleted the old file and downloaded started without a problem.
     
  8. MrNase macrumors member

    Joined:
    Jan 22, 2006
    Location:
    Germany
    #8
    Hey guys,

    same problems here… I had the installation file on my second hard drive but deleting that file didn't help at all.
    I see the Beta 4 in the list of items that I bought but I can't download it.

    I will now try to update Mavericks to see if that does any good.
     
  9. jackie-chan macrumors newbie

    jackie-chan

    Joined:
    Nov 12, 2014
    #9
    having the same issue :( except in my case i formatted my hdd, but it seems that the first instal of yosemite is still in the os x base system. anyone know how to get around this? thanks in advance if you do!
     

Share This Page