App Store: From Aperture 2 to Aperture 3

Discussion in 'Mac Apps and Mac App Store' started by Evangelion, Jan 6, 2011.

  1. Evangelion macrumors 68040

    Joined:
    Jan 10, 2005
    #1
    I noticed that Aperture 3 is priced really, REALLY low on the Mac App Store. So I made the decision to buy it. But... I already have Aperture 2 installed. So what happens when I buy Aperture 3? Does it recognize that I have Aperture 2 installed, and upgrade it, or will it install Aperture 3 alongside Aperture 2?
     
  2. MacProDude macrumors member

    Joined:
    Aug 16, 2006
    Location:
    SF Bay Area, CA
    #2
    Well, just make a copy of your Aperture 2 application just in case. If it overwrites, no big deal, you'll still have a copy. If it doesn't overwrite, then you can delete your extra copy as redundant. That's what I did when I upgraded to AP3 last year.

    Be aware that if you open AP3 with your AP2 library, it'll want (ask you) to convert the library from v2 to v3. If you do, then you can't use AP2 with that library anymore. If you want to still be able to use AP2, you'll want to make a copy of your v2 library.

    In any case, you probably won't ever want to go back to AP2 after using AP3.
     
  3. Evangelion thread starter macrumors 68040

    Joined:
    Jan 10, 2005
    #3
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    No, the question is not really about upgrading from Aperture 2 to Aperture 3. It's about upgrading to Aperture 3 through the App Store. Normally the app is replaced with the new version, but I'm talking about upgrading through the App Store.

    I know how to upgrade Aperture and what normally happens. Using DVD's that is. App Store is different, and my question is about the App Store.
     
  4. NoNameBrand macrumors 6502

    Joined:
    Nov 17, 2005
    Location:
    Halifax, Canada
    #4
    Aperture is entirely self contained in the .app. When I upgraded from 1 to 2 and then 2 to 3, I renamed the existing application and installed. I also had a backup of my library before I upgraded that on first launch of the first version. Really important to be able to roll-back if there's an issue.

    Do the same thing before you install the app-store version and you should be fine.
     

Share This Page