App Store in Yosemite

Discussion in 'OS X Yosemite (10.10)' started by autiger30, Nov 22, 2014.

  1. autiger30 macrumors newbie

    Joined:
    Aug 16, 2012
    #1
    Since updating I cannot download anything I click GET and nothing works. I go to updates and its just a white screen. Also I've noticed that when you go to System Pref and go to iCloud it says it cant load preference pane ... Any ideas?
     
  2. jdphoto macrumors 6502

    jdphoto

    Joined:
    Jan 13, 2014
    #2
    Sounds like a potential network issue. Are you able to access the internet normally through a web browser?
     
  3. eisenheim94 macrumors newbie

    Joined:
    Nov 22, 2014
    #3
    Have the same problem

    After upgrading to Yosemite yesterday I get problem with App Store. I can download apps from "Purchased", but other pages won't to load. White background :(
     
  4. jkundi macrumors member

    Joined:
    Mar 31, 2014
    #4
    Same issue I posted. I can't seem to find a fix.

    http://forums.macrumors.com/showthread.php?t=1821975
     
  5. autiger30 thread starter macrumors newbie

    Joined:
    Aug 16, 2012
    #5
    Yes I can browse the net fine. In regards to the other post I cannot even access purchased it tells me to sign in even though I am.
     
  6. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    Sign out from the App Store.
    Restart your Mac.
    Sign in again to App Store.
     
  7. autiger30 thread starter macrumors newbie

    Joined:
    Aug 16, 2012
    #7
    First thing I did, nada.
     
  8. umzyi macrumors regular

    umzyi

    Joined:
    Apr 21, 2011
    Location:
    UK
    #8
    I experienced the same issue. I solved it by: repairing permissions, resetting pram and smc. Once i did these steps, app store started working for me right away. Try these and see if it works :)
     
  9. jkundi macrumors member

    Joined:
    Mar 31, 2014
    #9
    Any good guides out there to follow, I've not done any of the above before.

    Thanks.
     
  10. jkundi macrumors member

    Joined:
    Mar 31, 2014
    #10
    Ok guys I've done all the suggested tips above. Still have the issues with App Store not loading categories view.

    Others have reported this issue too.
     
  11. autiger30 thread starter macrumors newbie

    Joined:
    Aug 16, 2012
    #11
    I'm at a loss, I am going to backup, wipe and start fresh.
     
  12. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #12
    I also get almost nothing in App Store/Categories view.

    To OP, IMHO reinstalling is not likely to help, as it appears to be a general issue, and likely on Apple's end. Give it a day or two...

    Or, you could contact Apple, where you might discover the real answer (or not :D ) https://www.apple.com/support/contact/
     
  13. autiger30 thread starter macrumors newbie

    Joined:
    Aug 16, 2012
    #13
    Well I'm back up and running like a charm. Fresh start is the way to go, I do think something was corrupt.
     
  14. mrwamck macrumors member

    Joined:
    Feb 7, 2013
    Location:
    Sweden
    #14
    App Store seems stuck!

    Since I've upgraded to OSx Yosemite 10.10 and now to 10.10.1 I think App Store is stuck. When I started App Store, because it said I had updates, I had 2 updates. One was Pages V5.5.1 and the other was PhotoSync V2.2. I then clicked on Update All and waited until it finished the updates. I then went on working and restarted my Macbook Pro and noticed that I had 2 updates again. I looked and they were the same updates to both Pages and PhotoSync. I click Update All again and waited until it finished. I then closed App Store and restarted it. 2 Updates again. I then moved both Pages and PhotoSync to the trash can, Emptied it and restart the machine. I then noticed 2 updates again. The same 2 programs even though I had deleted them. I then clicked Update All and waited until it finished. I then ran a Verify Permissions and noticed a few errors with iTunes so I ran Repair Permissions. I then restarted the machine again and still 2 updates. The same 2 programs, Pages and PhotoSync.

    What's going on? Never had this issue with Mavericks.
     
  15. jkundi macrumors member

    Joined:
    Mar 31, 2014
    #15
    I've done a clean install multiple times still the same, I've tried to contact Apple Support, been in a Q for 1hr for an adviser to answer, shocking. :rolleyes: Think I may give up.
     

Share This Page