App store issues after jailbreak?

Discussion in 'Jailbreaks and iOS Hacks' started by rheng, Feb 9, 2011.

  1. rheng macrumors newbie

    Joined:
    Jul 16, 2010
    #1
    Just updated from my 4.1 jailbreak to the 4.2 jailbreak with green poison. I did so by updating to 4.2, restoring from backup, performed the jailbreak, then restored with pkgbackup. Everything seemed to go fine, however, now when i try to install a new app or update apps via the app store, app store exits and has the "waiting" text and loading bar on the apps being added/updated, however, this only lasts for a couple seconds and then the app just disappears (if it is a new app im trying to install) or just returns to normal (if it is an app im updating). Is anyone else having this problem? Am i going to need to just re-jailbreak?
     
  2. STEVESKI07 macrumors 68000

    STEVESKI07

    Joined:
    Jan 6, 2009
    Location:
    Washington, DC
    #2
    Nope, not having this problem. I'd restore and jailbreak again. Try downloading an app from the app store before you use pkgbackup to see if that is the problem or if it was just a problem with your original jailbreak.
     
  3. h1r0ll3r macrumors 68040

    h1r0ll3r

    Joined:
    Dec 28, 2009
    Location:
    Maryland
    #3
    Might also want to try setting the phone up as new and not from your backup. Not ideal but sometimes it helps.
     
  4. headcase macrumors 6502

    headcase

    Joined:
    Jul 4, 2007
    Location:
    Raleigh, NC
    #4
    Most problems are caused by restoring from a backup, so your best bet is to install the JB on a clean stock firmware, and then installing the JB apps one by one. Sorry this is more painful of a process, but its the best way to ensure you have a bug-free iPhone. Too many cobwebs introduced when restoring JB apps.
     
  5. rheng thread starter macrumors newbie

    Joined:
    Jul 16, 2010
    #5
    so i tried doing a normal restore and then jailbreaking, still not working. So, i just restored it from my initial back up. However, now i get an error message saying it cant connect to the itunes store, but this only occurs when i try to update apps, i can install new ones just fine. :/
     
  6. TJone macrumors 6502a

    Joined:
    Aug 2, 2010
    #6
    I had a similar problem this morning. After a few reboots and signing in and out of the app store it finally fixed itself.
     

Share This Page