app store keeps saying theres an update when i updated

Discussion in 'iPhone Tips, Help and Troubleshooting' started by lakaiordie, Nov 5, 2008.

  1. lakaiordie macrumors 65816

    Joined:
    Jun 17, 2008
    #1
    i updated the motionx dice today. but it still has a little 1 by the app icon. when i go in, it says installed. but the little 1 over the icon wont go away. whats the deal?
     
  2. daisuke07 macrumors regular

    Joined:
    Oct 25, 2008
    #2
    mines doing the same thing!!!! Except it's with the say who app. I go to the app store and to the updates section and I click the app that needs an update but it says installed already so I can't update it but I reinstalled it which shpuldve made it go to the latest update and it don't work
     
  3. xrp123 macrumors newbie

    Joined:
    Sep 22, 2008
    #3
    Same here

    I noticed it yesterday when I installed the mini piano app. I deleted it, reinstalled and it still had the same issue.

    I just had to permanently delete the app to get rid of the update status.:confused:
     
  4. daisuke07 macrumors regular

    Joined:
    Oct 25, 2008
  5. zerogate macrumors newbie

    zerogate

    Joined:
    Oct 28, 2008
    Location:
    Oakley, CA
    #5
    Problems with app updates, red dot, annoying, already installed, etc.

    Hello,


    11-05-08. I don't think this problem will last too long.

    The problem is that a red update button appears on the app store icon and then when you go to update the app, it says "already installed", which eventually may drive you crazy.

    The update issue is happening with at least 3 other apps that I know of right now and does not appear to be associated to any developer mistakes at this time.

    I'm part of the development team behind MeterRead. Our app is having the same problem that is happening with the other apps. Here's an apple link http://discussions.apple.com/thread.jspa?messageID=8406928&tstart=0


    We submitted our first update from version 1.0.0 to 1.0.1 and it became "ready for sale" a few days ago, but I never saw an actual update happen. A colleague downloaded the app and the next day I asked him how he liked it and he jokingly said, "I'm not saying anything until I get this update out of the way!"

    This is a problem.

    So I decided to remove the app and re-install (which has always been a free process, but annoying because you have to commit to 'buy' before you get the message that it is "free", but that's another story!).

    I reloaded the app, verified that it was version 1.0.1 and then 10 to 15 seconds later the "update" red dot (with a big 2 on it now) re-appeared!

    That red dot.

    The "update" said "already installed" and was the previous version, 1.0.0!

    We will hopefully figure this out soon. It may be a "quick" fix with updating internal information within the app and resubmitting (and waiting for approval) or it is possible that apple will send out a macro to fix this soon.

    It looks like we are going through some changes with the App Store. (try to see all 1500 game apps lately using your phone?)

    I personally apologize if anyone had this problem with our app and rest assured, it will be fixed, either by us or another developer or our trusty Apple or all of us together!

    "It's not easy being green" -Kermit the Frog

    I guess we'll have to extend our $.99 sale for a few more days until this is figured out... This is temporary.


    Peace,

    :cool:Mark

    MeterRead
    www.zerogate.com
     
  6. Rat-Boy macrumors 65816

    Rat-Boy

    Joined:
    Jul 28, 2008
    Location:
    Georgia
    #6
    Yup.

    Happened to me with YouNote application.

    I finally just removed it because those Red Dots drive me nuts.

    Not sure why really. Maybe I am mental, but I digress.

    At any rate, I hope they fix it, because while I had no problem removing YouNote which I never used, I would not want to get rid of some of my other apps should this happen to those.
     
  7. bartelby macrumors Core

    Joined:
    Jun 16, 2004
    #7
    Same here. With the same app.
     
  8. BLACK MAC macrumors 6502

    Joined:
    Feb 9, 2007
    #8
    This is happening with me. I purchased 'Topple' and its saying I need an update on my iPhone. However on my computer, no update is needed. I just ended up deleting the program. I tried to reinstall to see if there was no updated need. Nothing. Still says I need an update. I hope they fix this soon!!
     
  9. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #9
    Same thing here with "MiniPiano."

    So I guess it's something with the store and not our phones. Oh well, I'll stop worrying about it then since there's nothing I can do.
     
  10. icewing macrumors 6502

    Joined:
    Jun 19, 2008
    Location:
    St Louis
    #10
    It ended up bugging me so much that I moved my App Store icon to the second page so I don't have to look at it all the time. Should have done that weeks ago...
     
  11. lakaiordie thread starter macrumors 65816

    Joined:
    Jun 17, 2008
    #11
    same here that red dot is annoying. i hope it gets fixed soon. seems like a problem on apples end.
     
  12. nickspohn macrumors 68040

    nickspohn

    Joined:
    Jun 9, 2007
    #12
    It seems to be a random bug that happens with random apps. If it happens i usually just delete the app.
     
  13. zerogate macrumors newbie

    zerogate

    Joined:
    Oct 28, 2008
    Location:
    Oakley, CA
    #13
    App Store updated

    11-6-08, 11:40pm PST. My apps that were stuck on "update" are gone and then I had 7 real updates pop up. Also, I'm getting a 'cannot connect to app store" message but I can look at some apps. Hopefully we be able to see all the apps and not just the first 100 soon.

    Mark
    MeterRead
    "Go Green, Save Green!"
     
  14. bluenoise macrumors 6502a

    Joined:
    Jul 16, 2008
    #14
    Same here for last night. My stuck app is Wurdle. I got the 'cannot connect to iTunes Store' message, but I was still able to browse and download new apps.
     
  15. nippyjun macrumors 65816

    Joined:
    Jul 26, 2007
    #15
    This started happeing with 2 of my apps. One is ok now but the other, woot watch keeps showing an update available.
     
  16. samcraig macrumors P6

    Joined:
    Jun 22, 2009
    #16
    Happened to me last night - tried reinstalling via the app store 3-4 times. Finally - I decided to reboot my phone. I did, clicked install in the app store and now everything is fine.

    Try rebooting
     
  17. romantx29 macrumors newbie

    Joined:
    Nov 11, 2009
    #17
    take caution with adding itunes upgrade

    T-mobile had a power outage last tuesday. I started having problems with my mms messaging on my iphone. Thought it might have something to do with that but however called t-mobile technical support and they couldnt fix. I think the root of these malfunctions have to do with the itunes upgrade on phone.
     

Share This Page