App store nightmare

Discussion in 'iOS 6' started by domroberts, Oct 20, 2012.

  1. domroberts macrumors newbie

    Joined:
    Sep 2, 2012
    #1
    Hi, I hope you can help. I'm having a nightmare with the App store on my iPhone 4 & iPad 2 both running iOS6.

    It started with apps not installing. I kept getting an error message saying that the app could not be downloaded at this time and giving me the option to press 'done' or 'retry'. Retry never worked. But if I click out of the app store app and I can sometimes find the offending app icon, with a stalled blue bar and pressing it would sometimes allow it to install.

    Further all the tabs - Featured, Charts, genius etc are blank. I get the little spinning wheel, but nothing loads.

    I tried to restore my iPhone via iTunes, but every time I just got an error message telling the downloaded update was corrupted and I should try later and check my network settings.

    I spoke to Apple who whilst very helpful were unable to sort it out. The lady suggested I try restoring from another user account on my iMac, but I got the same corrupted message.

    Anyway I managed to restore my phone directly on the device by erasing all data. But I couldn't get iCloud back up to work. I managed to use a back up off the iMac. Now the app store seems to be working, at least there are things on the screen, but all the tab icons have disappeared to be replaced by the generic Apple app icon of an 'A" made with a pencil and other bits. I am now back to square one with apps again refusing to download on my phone.

    My iPad is still the same with the blank white screens on the app store app. I haven't tried any kind of restore on that yet.

    I am concerned that it could have something to do with our new wifi network. But it does seem to work with everything else, internet etc.

    Sorry for such a long post. But I just want to add how this started.

    We moved house recently, a few weeks after iOS 6 was released. But it took a a few days to get the internet installed at the new house. I had already upgraded to iOS6 and it all seemed to be working fine at the old house. Anyway, down time with no internet I had about 16 app updates pending. Once the internet was up and running, I hit 'update all' and that is when it pretty much all started to go wrong. As at least half of the apps didn't download or stalled.

    I do have this problem on 3G as well.

    Any ideas?

    Best

    Dom
     
  2. Troneas macrumors 65816

    Troneas

    Joined:
    Oct 26, 2011
    Location:
    At the alternatives section.
    #2
    the app store is indeed a nightmare for users with older devices such as the IP 4 and the IPT 4G, iPad 2 and so on; but your issues are beyond problematic and it would seem related to connectivity - the appstore already works badly with wi-fi i wouldnt even try connecting over 3G.

    i would suggest you head over to a cafe or a friends house and connect to their network. if it works you know its not your phone.
     
  3. domroberts thread starter macrumors newbie

    Joined:
    Sep 2, 2012
    #3
    Hi Troneas,

    Thanks for your reply.

    I was about to post an update that it was all working again, but I think I jumped the gun a bit.

    At least the App store is showing up now and the tabs have their right icons and the screens are populated etc. It also shows the updates. However I am still unable to download anything over WiFi. Still getting the '"Insert App name" cannot be downloaded at this time' error message. I did manage to update a couple of apps over 3G (unfortunately mobile reception at our new home is very bad).

    It has just updated one app over wifi but couldn't do another one. I wonder if it is a size issue.

    I think though, that unfortunately wifi may be the problem and shall do as you suggest and try on another wifi network. This is extremely frustrating - what is the point of having superfast broadband!

    Dominic
     
  4. Troneas macrumors 65816

    Troneas

    Joined:
    Oct 26, 2011
    Location:
    At the alternatives section.
    #4
    sometimes its not about the speed.

    there are tons of connectivity issues such as router configuration or even outdated firmware; or issues with the modem.

    so before you go crazy its best to rule out the phone by checking on other places.
     
  5. domroberts thread starter macrumors newbie

    Joined:
    Sep 2, 2012
    #5
    Yes I'm sure you are right and will try and check out the phone on another wifi network.

    I don't know much about wifi connectivity, but the phone seems to connect to the Internet etc fine. Is there something different about the App Store.

    I was able to download and install an app over 3G this morning whilst out & about so I think it is definitely something to do with wifi, but whether it is the phone or the modem is yet to be determined.

    Still nothing on the iPad though, over 3G or My home wifi. I think I've still got AppleCare on the iPad and will call apple to see what they have to say.

    Thanks for your help.
     
  6. arcite macrumors 6502a

    arcite

    Joined:
    Sep 6, 2009
    Location:
    Cairo, trapped in a pyramid with my iphone
    #6
    I had some issues when I updated my ipad 3 to ios6 as well. The problem is not with the ipad, it is with your router. Try Logging into your router and play with the wifi settings, such as setting to only use one band, or even assigning a single band for the ipad to use.

    Frankly, the wifi reception on the ipad3 leaves much to be desired.
     
  7. domroberts thread starter macrumors newbie

    Joined:
    Sep 2, 2012
    #7
    Thanks arcite, I will have a look at my router settings - although it is a can of worms I'd rather not open.

    What I don't understand is that my iPhone & iPad2 can connect to the internet fine, just not the app store.

    My wife's iPhone 4S - still running ios5 - seems to be OK most of the time, although some apps download and install fine whilst others just don't. Why will Words with Friends update fine, whilst Brickbraker 3D just gets stuck half way through. I wonder if it has something to do with the size of the app?

    I wish I new more about wifi. I seem to have a very strong signal about 95%+. I wondered if it was dropping in and out, but I've down loaded a wifi tracker app and it only seems to fluctuate a few percentage points.

    Also the Signal To Noise ratio is 62. Is that good or bad? Signal is 95% and Noise 1% so I guess good?

    Best

    Dominic
     
  8. MozMan68 macrumors 68000

    MozMan68

    Joined:
    Jun 29, 2010
    Location:
    Right here...
    #8
    Also check your music downloads. Someone mentioned in another thread about this and sure enough, iTunes was trying to download 63 songs including a couple that had some sort of errors. These were causing the app updates (as well as the music) to freeze up.

    Since you don't actually see the song updates unless you are in the music app, it was out of sight, out of mind.
     
  9. Troneas macrumors 65816

    Troneas

    Joined:
    Oct 26, 2011
    Location:
    At the alternatives section.
    #9
    i've had problems in the past with certain apps (in my mac) not responding too well to a certain (quite basic to be honest) router whilst browsing the web worked just fine.

    i made the effort to buy a good router (which had the firmware outdated so i had to solve that too) and all is well.

    most of us cant begin to grasp what goes on in connectivity problems hence why there are specialists in the field - which get paid quite well for a reason.

    and the reason apple wont help you is because they too believe it has nothing to do with their product but some other external factor.

    AND you mentioned iCloud, which is an online service as well.
     
  10. charlituna macrumors G3

    charlituna

    Joined:
    Jun 11, 2008
    Location:
    Los Angeles, CA
    #10
    Couple of things come to mind

    Your wifi router might need an update. Either firmware or adjust the settings

    On the iPhone I have heard of folks having trouble in the App Store because he iPhone thinks it is the wrong date. Verizon and Sprint in particular have a weird bug with this. If you choose 'set time automatically' it comes from the cell tower and they have periodic hiccups where the tower says its like 1975 etc. there was one such hiccup on some Verizon towers about a week ago. Might still be happening.
     
  11. domroberts thread starter macrumors newbie

    Joined:
    Sep 2, 2012
    #11
    Thanks everyone for your suggestions.

    I almost hate to write this as I will probably jinx it, but I think I may have fixed the issue. At least I managed to get onto the app store and download some apps.

    Basically I switched the new superfast broadband router into modem mode (which basically turns off the wife and router functions) and then connected it to my airport extreme via ethernet and used the airport extreme as a wireless router. In effect putting all the mobile devices back on the old network they were on before we moved house.

    I think I may have sacrificed something in speed, but I'd rather have better connectivity.

    But we will see. It'll probably all have gone wrong by tonight!

    I'll keep you posted, but hopefully you won't hear from me again on this issue - fingers crossed.
     
  12. phpmaven macrumors 68040

    phpmaven

    Joined:
    Jun 12, 2009
    Location:
    San Clemente, CA USA
    #12
    I would connect to a friends wifi network and see if you have the same issues.
     
  13. domroberts thread starter macrumors newbie

    Joined:
    Sep 2, 2012
    #13
    Hi phomaven,

    I will try. Mine seems to be working now. I am now more than ever convinced that it is something to do with iOS 6. My wife's iPad 3 is now not working, and I'm pretty sure it was working before it was upgraded. I'm not sure when it was upgraded as I didn't upgraded it, but I'm pretty sure it was working before.

    It just won't connect to the App Store. The only thing that seems to work is the genius tab.

    Very frustrating.
     

Share This Page